<!doctype html><!--[if IE 8]><html class="no-js lt-ie10 lt-ie9" lang="en"><![endif]--><!--[if IE 9]><html class="no-js lt-ie10" lang="en"><![endif]--><!--[if gt IE 10]><!--><html class="no-js" lang="en" ><!--<![endif]--><head prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"><script type="text/javascript" src="https://www.gannett-cdn.com/uxstatic/daily-times/uscp-web-static-4525.35.0/js/partner/show_ads.js"></script><title>Donation drive continues through May 16 on San Juan College campus</title><meta content="text/html; charset=UTF-8" name="Content-Type" /><meta name="google" content="notranslate"><meta name="apple-itunes-app" content="app-id=1025204168"><meta name="description" content="Donors are asked to bring nonperishable food, bottled water, cleaning supplies and pet food to the San Juan College campus in Farmington."><link rel="canonical" href="https://www.daily-times.com/story/news/local/2020/05/11/donation-drive-continues-through-may-16-san-juan-college-campus/3101186001/"><link rel="amphtml" href="https://amp.daily-times.com/amp/3101186001" /><meta property="fb:app_id" content="138503963154406"/><meta property="fb:pages" content="6271782579,6566864515,6581478870,7197664863,7850621533,8031989578,9812439851,10482066215,11277320498,13642915529,13652355666,14073085963,16511263815,17540977705,18884137648,19125738813,23332504801,25003338948,31185662683,36808884697,37412800032,41044579289,42128399297,43612894510,46050757230,47020221001,47692649063,48490808881,48958576760,48976713989,49060990988,49607602899,49680588265,49896855793,50095226239,50978409031,52929678682,54660221594,55529405081,56434454301,56732457944,62464848082,62811590881,63475094632,63475094632,63582312713,65299040658,66049156099,66281684861,68903794473,69357466992,70423731350,70657021294,71807382333,72088679443,72139486384,73736978810,74475819815,76240820015,76276576343,77475586904,79333461561,79437403137,80117331717,80335432797,81086717085,81320873283,81668556783,81917682064,82415033847,83300095936,83563566820,87171906471,87448932499,87448932499,88584644204,90329609573,94480694479,94700656192,95712466848,95926318753,97657252278,99020906334,100825602361,101112717264,103261740968,103678546758,104331357951,104935809704,105714200321,105814368912,105878288262,106644919984,107327575587,108555442934,109146355881,109686244216,109793107867,110252103235,110404119877,110527555449,115611960606,115967868757,117907407522,118427210363,121866005065,122786733297,124755637015,125551044242,126226324691,129236178055,132159529312,132779306963,133049345480,134076752154,134394490084,136737914809,138770030135,141962110815,146089950343,148668982786,152774630192,153308622465,158094820767,164935760159,168684165430,173007618420,182922701188,188894693348,189867939238,190632318566,201996980631,227627281180,231239152914,242752084180,250325640686,264717798098,274620738925,275678631915,312966181232,314817944972,319611510288,323213251787,329923389135,338437548341,347221378913,362300531934,363363051861,371547464003,385926141498,427414745045,488720200095,100855786673970,105233922869839,105347532857165,105550656158763,106451856091222,106819879363130,107117249323169,108029922557289,108981615791456,109280192597421,109280192597421,109652569058713,110311752340743,110471702456365,110743725611909,110936258937026,111203872270080,112875149052352,113056925415668,113544088682099,113819202011100,115535341805950,115612465136194,117941352212869,119027288135308,119794264705307,119941731380546,120356424669462,121160355264720,121227371225765,121242251236815,121422567927897,124075397608772,124307640925620,124528254305153,127729820590459,128075747844406,129752560371732,130211193676772,130407246974813,130934216964240,136941796341905,137098406340114,137341919636249,137698179626815,137935586280481,138064052876960,138170199553897,140615052641118,140616965982144,141822679203700,142195472502819,143851392316295,145525478832716,146112055409819,146137498764266,146315142126130,146798045922062,147760805252234,148251148521543,149641051719383,152527031492851,152785861474173,153525871324757,154425934607982,154443518023678,155874144456588,156345381090801,157305941529632,157456661011568,158095147555989,159385590790009,160735830621443,161639923860040,165912253479205,167334979948476,167487199962004,169254356561132,169571899725267,169908223021026,176115302489104,176983469019018,177037772444433,177938742707529,180004588791896,183850168300771,183882195384562,184094471609920,184741935370451,185457134911754,187466604613310,187899791275353,190953458083653,192069610842446,196267627213508,197490563626275,205576782811630,207319989616043,209524799494208,212808112063652,220757414638542,222348701505747,224163964346315,225067797622802,225571757789261,225618707473378,231988790171331,235484153604672,236655713446291,236665340121443,241091022598958,243031846042424,251228454889939,261119230567728,263714980315631,279914708715884,281030418652036,281331052320274,285377081517877,288382484929799,288570077828603,295018040526596,297522096960113,305068052985746,307826419595702,310942265948388,315461641910509,315942225236045,315942225236045,320453738073595,321223331243188,327249521057460,330565860307724,332382433821098,334297859927211,339575256116022,351359635259904,353404615129492,368424599844024,373087836097009,399493863726488,401783903349050,405292372992577,410195352524708,412113499123835,420941268096348,421255071314156,422375144525783,426754640812333,438452439879553,458808827485318,469694573429026,471891632935599,477690595750196,480464022311783,487732368292520,510151039081225,535045576657973,535551216797440,556150611109468,562348203875693,566432520196581,569900189687627,581529871999163,592673674105043,593739520831583,611437275717153,637561026326153,642020402627050,677476185677499,686958778091339,704313986314492,717947288315597,756473301219510,757336147711096,813218208713830,850378298431411,872296879526971,877111212410602,911836215623184,917342785050040,927427260614748,945986872102221,1561238324154800,1822461518079800,1889753241275160,1003311406396687,1007667299356254,1095671673874517,1111939365618797,1170250869768985,1199725526840512,1203830176364044,1224613924286312,1244424538911767,1260369167415906,1282648301845288,1413320388972813,1422299337837954,1425793144356745,1432665186743737,1443524575938047,1473996709497771,1504884589584087,1525148737812812,1526198127405784,1583851541911383,1588113081458198,1596218533974035,1602646926431957,1603698749645413,1621466394844549,1627621717510471,1667234726635829,1725861847686522,1747180218844657,1759005871036426,1774393409526131,1797367867256626,1847787168808886,1878073225844519,1946209538938897,1972936962947967,2047091012096533" ><meta property="og:site_name" content="Farmington Daily Times" /><meta name="ROBOTS" content="NOODP, NOYDIR" /><meta property="og:image" content="https://www.gannett-cdn.com/presto/2020/05/08/PNM7/1be7a91f-36c2-4dea-82a8-f643f8ae53cd-0P1A9208.JPG?crop=3531,1986,x1,y186&width=3200&height=1680&fit=bounds"/><meta property="og:image:width" content="3200"/><meta property="og:image:height" content="1680"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://www.gannett-cdn.com/presto/2020/05/08/PNM7/1be7a91f-36c2-4dea-82a8-f643f8ae53cd-0P1A9208.JPG?crop=3531,1986,x1,y186&width=1600&height=800&fit=bounds"/><meta name="twitter:site" content="@TheDailyTimes" /><meta name="twitter:creator" content="@TheDailyTimes" /><meta name="twitter:title" content="San Juan College still seeking donations for Navajo Nation amid COVID-19 crisis" /><meta name="twitter:description" content="Donors are asked to bring nonperishable food, bottled water, cleaning supplies and pet food to the San Juan College campus in Farmington." /><meta property="og:title" content="San Juan College still seeking donations for Navajo Nation amid COVID-19 crisis"/><meta property="og:description" class="speakable-description" content="Donors are asked to bring nonperishable food, bottled water, cleaning supplies and pet food to the San Juan College campus in Farmington."/><meta property="og:url" content="https://www.daily-times.com/story/news/local/2020/05/11/donation-drive-continues-through-may-16-san-juan-college-campus/3101186001/"><meta property="og:type" content="article"/><meta property="article:opinion" content="false"><meta property="article:content_tier" content="metered"><meta property="article:author" content="Mike Easterling" /><script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "NewsArticle",
        "headline": "San Juan College still seeking donations for Navajo Nation amid COVID-19 crisis",
        "description": "Donors are asked to bring nonperishable food, bottled water, cleaning supplies and pet food to the San Juan College campus in Farmington.",
        "url": "https://www.daily-times.com/story/news/local/2020/05/11/donation-drive-continues-through-may-16-san-juan-college-campus/3101186001/",
        "isBasedOn": "https://www.daily-times.com/story/news/local/2020/05/11/donation-drive-continues-through-may-16-san-juan-college-campus/3101186001/",
        "mainEntityOfPage": {
            "@type": "WebPage",
            "@id": "https://www.daily-times.com/story/news/local/2020/05/11/donation-drive-continues-through-may-16-san-juan-college-campus/3101186001/"
        },
        "thumbnailUrl": "https://www.gannett-cdn.com/presto/2020/05/08/PNM7/1be7a91f-36c2-4dea-82a8-f643f8ae53cd-0P1A9208.JPG?crop=2577,2577,x766,y0&width=150&height=150&fit=bounds",
        "image": {
            "@type": "ImageObject",
            "url": "https://www.gannett-cdn.com/presto/2020/05/08/PNM7/1be7a91f-36c2-4dea-82a8-f643f8ae53cd-0P1A9208.JPG?crop=3531,1986,x1,y186&width=1600&height=800&fit=bounds",
            "height": 800,
            "width": 1600
        },
        "dateCreated": "2020-05-11T00:11:02.741Z",
        "dateModified": "2020-05-11T00:11:02.741Z",
        "datePublished": "2020-05-11T00:11:02.741Z",
        "articleSection": "news",
        "publisher": {
            "@type": "Organization",
            "name": "Farmington Daily Times",
            "logo": {
                "@type": "ImageObject",
                "url": "https://www.gannett-cdn.com/sites/daily-times/images/site-nav-logo@2x.png",
                "height": 80,
                "width": 297
            }
        },
        "author": ["Mike Easterling"],
        "keywords": [
            "ssts:news:local",
            "type:story",
            "tag:San Juan College",
            "tag:Navajo Nation",
            "tag:Health",
            "tag:Coronavirus COVID-19",
            "tag:Donations and Donating"
        ]
    }
    </script><meta name="viewport" content="width=1070" /><link rel="shortcut icon" href="https://www.gannett-cdn.com/sites/daily-times/images/favicon.png"><link rel="preload" href="https://www.gannett-cdn.com/gannett-web/global/fonts/unify/UnifySans_W_Rg.woff2" as="font" type="font/woff2" crossorigin="anonymous"><link rel="preload" href="https://www.gannett-cdn.com/gannett-web/global/fonts/unify/UnifySans_W_Bd.woff2" as="font" type="font/woff2" crossorigin="anonymous"><link rel="preload" href="https://www.gannett-cdn.com/gannett-web/global/fonts/unify/UnifySans_W_SBd.woff2" as="font" type="font/woff2" crossorigin="anonymous"><link rel="preload" href="https://www.gannett-cdn.com/gannett-web/global/fonts/gannettIcons/gannett-icons.woff" as="font" type="font/woff" crossorigin="anonymous"><!--[if gt IE 9]><!--><link data-identifier="main" rel="stylesheet" href="https://www.gannett-cdn.com/uxstatic/daily-times/uscp-web-static-4525.35.0/css/bundles/main_modern.min.css"><!--<![endif]--><!--[if IE 9]><link data-identifier="main" rel="stylesheet" href="https://www.gannett-cdn.com/uxstatic/daily-times/uscp-web-static-4525.35.0/css/bundles/common.min.css"><link data-identifier="main" rel="stylesheet" href="https://www.gannett-cdn.com/uxstatic/daily-times/uscp-web-static-4525.35.0/css/bundles/main.min.css"><link data-identifier="main" rel="stylesheet" href="https://www.gannett-cdn.com/uxstatic/daily-times/uscp-web-static-4525.35.0/css/bundles/dynamic.min.css"><![endif]--><!--[if IE 8]><link data-identifier="main" rel="stylesheet" href="/uxstatic/daily-times/uscp-web-static-4525.35.0/css/bundles/common.min.css"><link data-identifier="main" rel="stylesheet" href="/uxstatic/daily-times/uscp-web-static-4525.35.0/css/bundles/main.min.css"><link data-identifier="main" rel="stylesheet" href="/uxstatic/daily-times/uscp-web-static-4525.35.0/css/bundles/dynamic.min.css"><![endif]--><link rel="stylesheet" href="https://www.gannett-cdn.com/uxstatic/daily-times/uscp-web-static-4525.35.0/css/print.css" media="print"><!--[if gt IE 8]><!--><style>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</style><!--<![endif]--><!--[if lt IE 9]><link rel="stylesheet" href="/services/css/configs.css"><![endif]--><style></style><!--[if lt IE 9]><script src="https://www.gannett-cdn.com/uxstatic/daily-times/uscp-web-static-4525.35.0/js/libs/html5shiv-printshiv.js"></script><script src="https://www.gannett-cdn.com/uxstatic/daily-times/uscp-web-static-4525.35.0/js/libs/respond/respond.min.js"></script><![endif]--><!-- OneTrust Cookies Consent Notice start --><script src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" type="text/javascript" charset="UTF-8" data-domain-script="14183173-d419-467b-ba18-1740a15303e0"></script><script type="text/javascript">function OptanonWrapper() { }</script><script src="https://cdn.cookielaw.org/opt-out/otCCPAiab.js" type="text/javascript" charset="UTF-8" ccpa-opt-out-ids="4,5" ccpa-opt-out-geo="us" ccpa-opt-out-lspa="true"></script><!-- OneTrust Cookies Consent Notice end --><script type="text/javascript">
        (function(){
            window.privacyConfig = {
                strictlyNecessary: true,
                performance: true,
                functional: true,
                targeting: true,
                socialMedia: true,
                isCcpaSubject: false
            };
            var consentCookieName = 'OptanonConsent';
            if (document.cookie.indexOf(consentCookieName) !== -1) {
                var catIds = {
                    1: 'strictlyNecessary',
                    2: 'performance',
                    3: 'functional',
                    4: 'targeting',
                    5: 'socialMedia'
                };
                function getCookie(name) {
                    var value = "; " + document.cookie;
                    var parts = value.split("; " + name + "=");
                    if (parts.length === 2) return parts.pop().split(";").shift();
                }
                var ocCookie = getCookie(consentCookieName);
                if (ocCookie) {
                    ocCookie = decodeURIComponent(ocCookie);
                    var cookieParamGroups = ocCookie.split('&');
                    var cookieParams = {};
                    for (i=0; i<cookieParamGroups.length; i++) {
                        var splitGroup = cookieParamGroups[i].split('=');
                        if (splitGroup[1]) {
                            cookieParams[splitGroup[0]] = splitGroup[1];
                        }
                    }
                    if (cookieParams.groups) {
                        var groups = cookieParams.groups.split(',');
                        for (var i=0; i<groups.length; i++) {
                            var cat = groups[i].split(':');
                            var catId = parseInt(cat[0]);
                            if (catId) {
                                var catName = catIds[catId];
                                if (catName) {
                                    window.privacyConfig[catName] = !!parseInt(cat[1]);
                                }
                            }
                        }
                    }
                    window.privacyConfig.isCcpaSubject = true;
                }
            }
        })();
    </script><script type="text/javascript">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</script><script async type="text/javascript" src="//try.abtasty.com/bcf3f16fe6dfff2da9b2400d218df47c.js"></script></head><body class=" site-theme-dark-blue body-dr-styling " ><header data-fixed="false" data-open="true" data-default-fixed="false" data-default-open="true" class=" site-header header-light "><div class="site-header-inner-wrap "><div class="partner-nanobar"><div class="partner-placement partner-nanobar-ad" data-ad-placement="consumer_sales-nano_bar" data-ad-sizes="[[1025,80], 'fluid']"></div></div><div class="site-masthead"><a class="site-masthead-logo-link logo-link" data-ht="Headerdaily-times Headerlogoexpanded" href="/" ><img class="site-masthead-logo-img" src="https://www.gannett-cdn.com/sites/daily-times/images/site-masthead-logo-dark@2x.png" height="80" alt="Farmington Daily Times"></a><div class="site-masthead-search-wrap"><form class="site-masthead-search-form ui-ajax-form" action="/search/" method="get" data-mapping="<%= q %>/"><div class="site-masthead-subscribe-wrap site-masthead-subscribe-wrap-visible"><a href="https://subscribe.daily-times.com/?gps-source=CPHPPRIMARY&amp;utm_medium=ONSITE&amp;utm_content=CPHPPRIMARY&amp;utm_source=CPHPPRIMARY" class="userAuth-redirect site-masthead-subscribe-link" data-ht="Headersubscribecallout" target="_blank"><span class="site-masthead-subscribe-primary-text">SUBSCRIBE NOW</span><span class="site-masthead-subscribe-secondary-text">for full access</span></a></div><div class="site-masthead-special-offers-ad partner-placement" data-ad-placement="consumer_sales-masthead" data-ad-sizes="[[122,50]]"></div></form></div></div><nav class="site-nav"><ul class="site-nav-list site-nav-list-daily-times more-link-variant"><li class="site-nav-item site-nav-end-item site-nav-logo-item"><a class="site-nav-link site-nav-logo-link" data-ht="Headerlogocollapsed" href="/"  ><img class="site-nav-logo-img " src="https://www.gannett-cdn.com/sites/daily-times/images/site-nav-logo-dark@2x.png" height="40" alt="Farmington Daily Times"></a></li><li class="site-nav-item site-nav-item-theme-dark-blue site-nav-primary-item site-nav-end-item site-nav-first-primary-item site-nav-text-item site-nav-home-item site-nav-module site-nav-home-module" id="module-position-SsqVKb0Wios"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-daily-times site-nav-link-theme-dark-blue site-nav-end-link site-nav-first-primary-link site-nav-text-link site-nav-home-link" href="/" data-ht="Headerhome"><span class="site-nav-span site-nav-span-theme-dark-blue site-nav-end-span site-nav-first-primary-span site-nav-text-span site-nav-home-span">Home</span><span class="site-nav-theme-border home-theme-bg dark-blue-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-blue site-nav-primary-item site-nav-text-item site-nav-news-item site-nav-module site-nav-news-module" id="module-position-SsqVKb1dj_o"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-daily-times site-nav-link-theme-dark-blue site-nav-text-link site-nav-news-link" href="/news/" data-ht="Headernews"><span class="site-nav-span site-nav-span-theme-dark-blue site-nav-text-span site-nav-news-span">News</span><span class="site-nav-theme-border news-theme-bg dark-blue-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-blue site-nav-primary-item site-nav-text-item site-nav-sports-item site-nav-module site-nav-sports-module" id="module-position-SsqVKb0bwlw"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-daily-times site-nav-link-theme-dark-blue site-nav-text-link site-nav-sports-link" href="/sports/" data-ht="Headersports"><span class="site-nav-span site-nav-span-theme-dark-blue site-nav-text-span site-nav-sports-span">Sports</span><span class="site-nav-theme-border sports-theme-bg dark-blue-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-blue site-nav-primary-item site-nav-text-item site-nav-business-item site-nav-module site-nav-business-module" id="module-position-SsqVKb1akAM"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-daily-times site-nav-link-theme-dark-blue site-nav-text-link site-nav-business-link" href="/business/" data-ht="Headerbusiness"><span class="site-nav-span site-nav-span-theme-dark-blue site-nav-text-span site-nav-business-span">Business</span><span class="site-nav-theme-border business-theme-bg dark-blue-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-blue site-nav-primary-item site-nav-text-item site-nav-entertainment-item site-nav-module site-nav-entertainment-module" id="module-position-SsqVKb0esGc"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-daily-times site-nav-link-theme-dark-blue site-nav-text-link site-nav-entertainment-link" href="/entertainment/" data-ht="Headerentertainment"><span class="site-nav-span site-nav-span-theme-dark-blue site-nav-text-span site-nav-entertainment-span">Entertainment</span><span class="site-nav-theme-border entertainment-theme-bg dark-blue-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-blue site-nav-primary-item site-nav-text-item site-nav-lifestyle-item site-nav-module site-nav-lifestyle-module" id="module-position-SsqVKb0Nxfs"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-daily-times site-nav-link-theme-dark-blue site-nav-text-link site-nav-lifestyle-link" href="/lifestyle/" data-ht="Headerlifestyle"><span class="site-nav-span site-nav-span-theme-dark-blue site-nav-text-span site-nav-lifestyle-span">Lifestyle</span><span class="site-nav-theme-border lifestyle-theme-bg dark-blue-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-blue site-nav-primary-item site-nav-text-item site-nav-opinion-item site-nav-module site-nav-opinion-module" id="module-position-SsqVKb0jtRI"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-daily-times site-nav-link-theme-dark-blue site-nav-text-link site-nav-opinion-link" href="/opinion/" data-ht="Headeropinion"><span class="site-nav-span site-nav-span-theme-dark-blue site-nav-text-span site-nav-opinion-span">Opinion</span><span class="site-nav-theme-border opinion-theme-bg dark-blue-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-blue site-nav-primary-item site-nav-text-item site-nav-obituaries-item site-nav-module site-nav-obituaries-module" id="module-position-SsqVKb1vVGM"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-daily-times site-nav-link-theme-dark-blue site-nav-external-text-link site-nav-text-link site-nav-obituaries-link" href="https://www.legacy.com/obituaries/daily-times/" data-ht="Headerobituaries" target="_blank"><span class="site-nav-span site-nav-span-theme-dark-blue site-nav-text-span site-nav-obituaries-span">Obituaries</span><span class="site-nav-theme-border obituaries-theme-bg dark-blue-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-blue site-nav-primary-item site-nav-text-item site-nav-homes-item site-nav-module site-nav-homes-module" id="module-position-SsqVKb0xnAg"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-daily-times site-nav-link-theme-dark-blue site-nav-text-link site-nav-homes-link" href="/marketplace/real-estate/" data-ht="Headerhomes"><span class="site-nav-span site-nav-span-theme-dark-blue site-nav-text-span site-nav-homes-span">Homes</span><span class="site-nav-theme-border homes-theme-bg dark-blue-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-blue site-nav-primary-item site-nav-text-item site-nav-usa-today-item site-nav-module site-nav-usa-today-module" id="module-position-SsqVKb02_Tg"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-daily-times site-nav-link-theme-dark-blue site-nav-external-text-link site-nav-text-link site-nav-usa-today-link" href="https://www.usatoday.com" data-ht="Headerusa-today" target="_blank"><span class="site-nav-span site-nav-span-theme-dark-blue site-nav-text-span site-nav-usa-today-span">USA Today</span><span class="site-nav-theme-border usa-today-theme-bg dark-blue-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-blue site-nav-primary-item site-nav-icon-item site-nav-media-item site-nav-module site-nav-media-module" id="module-position-SsqVKb0oPh4"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-daily-times site-nav-link-theme-dark-blue site-nav-icon-link site-nav-media-link" href="/media/latest/news/" data-ht="Headermedia"><span class="site-nav-span site-nav-span-theme-dark-blue site-nav-icon-span site-nav-media-span">Media</span><span class="site-nav-theme-border media-theme-bg dark-blue-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-blue site-nav-primary-item site-nav-text-item site-nav-public-notices-item site-nav-module site-nav-public-notices-module" id="module-position-SsqVKb1Fl0A"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-daily-times site-nav-link-theme-dark-blue site-nav-external-text-link site-nav-text-link site-nav-public-notices-link" href="http://www.publicnoticeads.com/NM/" data-ht="Headerpublic-notices" target="_blank"><span class="site-nav-span site-nav-span-theme-dark-blue site-nav-text-span site-nav-public-notices-span">Public Notices</span><span class="site-nav-theme-border public-notices-theme-bg dark-blue-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-blue site-nav-primary-item site-nav-text-item site-nav-classifieds-item site-nav-module site-nav-classifieds-module" id="module-position-SsqVKb1du3g"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-daily-times site-nav-link-theme-dark-blue site-nav-external-text-link site-nav-text-link site-nav-classifieds-link" href="http://classifieds.daily-times.com/" data-ht="Headerclassifieds" target="_blank"><span class="site-nav-span site-nav-span-theme-dark-blue site-nav-text-span site-nav-classifieds-span">Classifieds</span><span class="site-nav-theme-border classifieds-theme-bg dark-blue-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-blue site-nav-primary-item site-nav-text-item site-nav-business-directory-item site-nav-module site-nav-business-directory-module" id="module-position-SsqVKb1flgc"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-daily-times site-nav-link-theme-dark-blue site-nav-external-text-link site-nav-text-link site-nav-business-directory-link" href="https://local.daily-times.com/" data-ht="Headerbusiness-directory" target="_blank"><span class="site-nav-span site-nav-span-theme-dark-blue site-nav-text-span site-nav-business-directory-span">Business Directory</span><span class="site-nav-theme-border business-directory-theme-bg dark-blue-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-blue site-nav-primary-item site-nav-text-item site-nav-celebrations-item site-nav-module site-nav-celebrations-module" id="module-position-SsqVKb3FlQ4"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-daily-times site-nav-link-theme-dark-blue site-nav-external-text-link site-nav-text-link site-nav-celebrations-link" href="http://www.legacy.com/celebration/daily-times/" data-ht="Headercelebrations" target="_blank"><span class="site-nav-span site-nav-span-theme-dark-blue site-nav-text-span site-nav-celebrations-span">Celebrations</span><span class="site-nav-theme-border celebrations-theme-bg dark-blue-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-blue site-nav-primary-item site-nav-end-item site-nav-last-primary-item site-nav-text-item site-nav-in-memoriam-item site-nav-module site-nav-in-memoriam-module" id="module-position-SsqVKb2Jtu8"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-daily-times site-nav-link-theme-dark-blue site-nav-end-link site-nav-last-primary-link site-nav-external-text-link site-nav-text-link site-nav-in-memoriam-link" href="https://www.legacy.com/obituaries/daily-times/" data-ht="Headerin-memoriam" target="_blank"><span class="site-nav-span site-nav-span-theme-dark-blue site-nav-end-span site-nav-last-primary-span site-nav-text-span site-nav-in-memoriam-span">In Memoriam</span><span class="site-nav-theme-border in-memoriam-theme-bg dark-blue-theme-bg" ></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-blue site-nav-primary-item site-nav-more-item site-nav-text-item site-nav-module site-nav-text-module" id="module-position-"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-daily-times site-nav-link-theme-dark-blue site-nav-more-link site-nav-text-link" href="" data-ht="Headertext"><div class="site-nav-span-wrap site-nav-more-span-wrap"><span class="site-nav-span site-nav-span-theme-dark-blue site-nav-more-span site-nav-text-span">More<span class="site-nav-more-arrow"></span></span></div></a><div class="site-nav-dropdown site-nav-more-dropdown site-nav-more-dropdown-1col"><div class="site-nav-dropdown-inner-wrap site-nav-more-dropdown-inner-wrap"><ul class="site-nav-more-dropdown-list site-nav-more-dropdown-list-1col"><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="/" data-ht="Headermorehome">Home</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="/news/" data-ht="Headermorenews">News</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="/sports/" data-ht="Headermoresports">Sports</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="/business/" data-ht="Headermorebusiness">Business</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="/entertainment/" data-ht="Headermoreentertainment">Entertainment</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="/lifestyle/" data-ht="Headermorelifestyle">Lifestyle</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="/opinion/" data-ht="Headermoreopinion">Opinion</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="https://www.legacy.com/obituaries/daily-times/" data-ht="Headermoreobituaries">Obituaries</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="/marketplace/real-estate/" data-ht="Headermorehomes">Homes</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="https://www.usatoday.com" data-ht="Headermoreusa-today">USA Today</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="/media/latest/news/" data-ht="Headermoremedia">Media</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="http://www.publicnoticeads.com/NM/" data-ht="Headermorepublic-notices">Public Notices</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="http://classifieds.daily-times.com/" data-ht="Headermoreclassifieds">Classifieds</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="https://local.daily-times.com/" data-ht="Headermorebusiness-directory">Business Directory</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="http://www.legacy.com/celebration/daily-times/" data-ht="Headermorecelebrations">Celebrations</a></li><li class="site-nav-more-dropdown-item site-nav-more-dropdown-item-1col"><a class="site-nav-more-dropdown-link" href="https://www.legacy.com/obituaries/daily-times/" data-ht="Headermorein-memoriam">In Memoriam</a></li></ul></div></div></span></li><li class="site-nav-item site-nav-item-theme-dark-blue site-nav-midway-item site-nav-end-item site-nav-first-midway-item site-nav-end-item site-nav-last-midway-item site-nav-icon-item site-nav-search-item site-nav-module site-nav-search-module" id="module-position-SsqVKb1_fYA"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-daily-times site-nav-link-theme-dark-blue site-nav-end-link site-nav-first-midway-link site-nav-end-link site-nav-last-midway-link site-nav-icon-link site-nav-search-link" href="" data-ht="Headersearch"><div class="site-nav-span-wrap site-nav-icon-span-wrap"><span class="site-nav-span site-nav-span-theme-dark-blue site-nav-end-span site-nav-first-midway-span site-nav-end-span site-nav-last-midway-span site-nav-icon-span site-nav-search-span">search</span></div><span class="site-nav-theme-border search-theme-bg dark-blue-theme-bg" ></span></a><div class="site-nav-dropdown site-nav-search-dropdown"><div class="site-nav-dropdown-inner-wrap site-nav-search-dropdown-inner-wrap"><form class="site-masthead-search-form ui-ajax-form" action="/search/" method="get" data-mapping="<%= q %>/"><input class="site-masthead-search-form-input" data-clearable="true" type="text" name="q" autocomplete="off" placeholder="Search"><button class="site-masthead-search-form-submit" type="submit" value=""></button></form></div></div></span></li><li class="site-nav-item site-nav-item-theme-dark-blue site-nav-primary-item site-nav-spacer-item site-nav-spacer-item site-nav-module site-nav-spacer-module" id="module-position-"><span class="site-nav-inner-wrap"></span></li><li class="site-nav-item site-nav-item-theme-dark-blue site-nav-secondary-item site-nav-end-item site-nav-first-secondary-item site-nav-subscribe-alt-item site-nav-subscribe-alt-item site-nav-module site-nav-subscribe-alt-module" id="module-position-SsqVKb3VpO0"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-daily-times site-nav-link-theme-dark-blue site-nav-end-link site-nav-first-secondary-link site-nav-external-subscribe-alt-link site-nav-subscribe-alt-link site-nav-subscribe-alt-link" href="https://subscribe.daily-times.com/specialoffer?gps-source=CPNAVBARBBB" data-ht="Headersubscribe-alt" target="_blank"><span class="site-nav-span site-nav-span-theme-dark-blue site-nav-end-span site-nav-first-secondary-span site-nav-subscribe-alt-span site-nav-subscribe-alt-span">Subscribe</span><span class="site-nav-subscribe-alt-bg subscribe-alt-bg-daily-times"></span></a></span></li><li class="site-nav-item site-nav-item-theme-dark-blue site-nav-secondary-item site-nav-end-item site-nav-last-secondary-item site-nav-salutation-item site-nav-salutation-item site-nav-module site-nav-salutation-module" id="module-position-SsqVKb213XU"><span class="site-nav-inner-wrap"><a class=" site-nav-link site-nav-link-daily-times site-nav-link-theme-dark-blue site-nav-end-link site-nav-last-secondary-link site-nav-salutation-link site-nav-salutation-link" href="" data-ht="Headersalutation"><div class="site-nav-span-wrap site-nav-salutation-span-wrap"><span class="site-nav-span site-nav-span-theme-dark-blue site-nav-end-span site-nav-last-secondary-span site-nav-salutation-span site-nav-salutation-span">salutation</span></div><span class="salutation-nav-arrow"></span></a><div class="site-nav-dropdown snsm-dropdown"><div class="snsm-wrap snsm-wrap-daily-times"><ul class="snsm-links"><li><a class="snsm-link snsm-link-view-account" href="https://account.daily-times.com/"><span class="snsm-link-text">Manage Account</span></a></li><li data-hoverDropdown="e-edition print"><a class="snsm-link snsm-link-eedition" href="https://user.daily-times.com/user/enewspaper"><span class="snsm-link-text">Access e-Edition</span></a></li><li data-hoverDropdown="!print"><a class="snsm-link snsm-link-newsletters" href="//profile.daily-times.com/newsletters/manage"><span class="snsm-link-text">Newsletters</span></a></li><li data-hoverDropdown="print"><a class="snsm-link snsm-link-pay-bill" href="https://account.daily-times.com/pay"><span class="snsm-link-text">Pay Bill</span></a></li><li data-hoverDropdown="print"><a class="snsm-link snsm-link-delivery-issues" href="https://account.daily-times.com/delivery-issue"><span class="snsm-link-text">Report Delivery Issues</span></a></li><li data-hoverDropdown="print"><a class="snsm-link snsm-link-stop-restart" href="https://account.daily-times.com/delivery-temporary-stop"><span class="snsm-link-text">Pause Delivery</span></a></li><li><a class="snsm-link snsm-link-member-guide" href="/memberguide/"><span class="snsm-link-text">Subscriber Guide</span></a></li><li><a class="snsm-link snsm-link-help" href="//help.daily-times.com"><span class="snsm-link-text">Help Center</span></a></li><li><a class="snsm-link snsm-link-sign-out hidden" href="https://user.daily-times.com/PNM7-GUP/user/logout/?return-url=https%3A//www.daily-times.com/story/news/local/2020/05/11/donation-drive-continues-through-may-16-san-juan-college-campus/3101186001/"><span class="snsm-link-text">Sign Out</span></a></li></ul><div class="snsm-sign-in"><div class="snsm-section"><p class="snsm-text">Have an existing account?</p><a class="snsm-btn snsm-link-sign-in" rel="nofollow" data-ht="HeaderUserAuthLogin" data-user-account="firefly" href="https://login.daily-times.com/PNM7-GUP/authenticate/?success-url=https%3A//www.daily-times.com/story/news/local/2020/05/11/donation-drive-continues-through-may-16-san-juan-college-campus/3101186001/&cancel-url=https%3A//www.daily-times.com/story/news/local/2020/05/11/donation-drive-continues-through-may-16-san-juan-college-campus/3101186001/"><span class="snsm-btn-text">Sign In</span></a></div><div class="snsm-section"><p class="snsm-text">Already have a subscription?</p><a class="snsm-btn snsm-link-activate" href="https://cm.daily-times.com/account-activation/">Activate Your Account</a></div><div class="snsm-section"><p class="snsm-text snsm-text-register">Don't have an account?</p><a class="snsm-register" href="https://login.daily-times.com/authenticate?requested-state=create-account&amp;reg_source=CPNAVBAR&amp;reg_medium=ONSITE&amp;reg_campaign=signin&amp;reg_delivery=ux"><span class="snsm-register-text">Create One</span></a></div></div></div></div></span></li></ul></nav><div class="bnm-container"></div></div><script type="json/headermodules" class="headermodules headermodules-primary">{ "js_modules": [{"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "SsqVKb0Wios", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "SsqVKb1dj_o", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "SsqVKb0bwlw", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "SsqVKb1akAM", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "SsqVKb0esGc", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "SsqVKb0Nxfs", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "SsqVKb0jtRI", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "SsqVKb1vVGM", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "SsqVKb0xnAg", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "SsqVKb02_Tg", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "SsqVKb0oPh4", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "SsqVKb1Fl0A", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "SsqVKb1du3g", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "SsqVKb1flgc", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "SsqVKb3FlQ4", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "SsqVKb2Jtu8", "options": null, "oembedprovider": null}] }</script><script type="json/headermodules" class="headermodules headermodules-post-primary">{ "js_modules": [{"name": "site-nav-search-module", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "SsqVKb1_fYA", "options": null, "oembedprovider": null}] }</script><script type="json/headermodules" class="headermodules headermodules-secondary">{ "js_modules": [{"name": "site-nav-salutation-module", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "SsqVKb213XU", "options": null, "oembedprovider": null}, {"name": "link", "oembedtype": null, "layoutType": "NAV_MODULES", "position": "SsqVKb3VpO0", "options": null, "oembedprovider": null}] }</script></header><div id="overlay"><div class="partner-placement partner-gravity-ad partner-gravity-ad-"><div class="gravity-viewable" id="gravity-viewable"></div><div class="partner-scroll"><div class="partner-scroll-circle"></div><p class="partner-scroll-message">Get the news</p></div></div><div class="transition-wrap" ><div class="partner-placement partner-brandlock" data-ad-placement="sponsor_logo" data-ad-sizes="[[300, 50]]"></div><div class="partner-placement partner-overlay-top-ad partner-has-min-height" style="min-height:250px" data-ad-placement="high_impact" data-ad-sizes="[[970,250],[728,90]]"></div><article class="asset story clearfix" ><div class="close-wrap"><a href="#" class="close close-overlay" data-ht="modalclose"></a></div><div class="utility-bar-wrap"><div class="utility-bar"><div class="util-bar-primary-modules"><div class="util-bar-module util-bar-module-share"><div
                    class="util-bar-btn util-bar-btn-facebook util-bar-btn-share"
                    data-module-name="utility-bar-module-share"
                    data-module-section="share"
                    data-uotrack="UtilityBarFacebookBtn"></div><a
                    class="util-bar-btn util-bar-btn-twitter"
                    data-module-name="share-twitter"
                    data-popup-width="550"
                    data-popup-height="450"
                    data-uotrack="UtilityBarTwitterLink"
                    href="https://twitter.com/intent/tweet?url=https%3A//www.daily-times.com/story/news/local/2020/05/11/donation-drive-continues-through-may-16-san-juan-college-campus/3101186001/&amp;text=San%20Juan%20College%20still%20seeking%20donations%20for%20Navajo%20Nation%20amid%20COVID-19%20crisis&amp;via=TheDailyTimes"
                    target="_blank" data-popup
                    rel="nofollow"></a><a class="util-bar-btn util-bar-btn-linkedin"
                    data-share-method="linkedin"
                    data-popup-width="600"
                    data-popup-height="455"
                    data-uotrack="UtilityBarFlyoutLinkedInLink"
                    href="http://www.linkedin.com/shareArticle?url=https%3A//www.daily-times.com/story/news/local/2020/05/11/donation-drive-continues-through-may-16-san-juan-college-campus/3101186001/&amp;mini=true"
                    target="_blank" data-popup
                    rel="nofollow"></a><div
                    class="util-bar-btn util-bar-btn-email js-share-email-btn"
                    data-module-name="utility-bar-module-share"
                    data-module-section="email"
                    data-uotrack="UtilityBarEmailBtn"></div><div class="util-bar-flyout util-bar-flyout-share"><div class="util-bar-flyout-pane util-bar-flyout-pane-share scrollable-content"><div class="util-bar-flyout-heading util-bar-flyout-heading-share"><h6 class="util-bar-flyout-title util-bar-flyout-title-share">Share This Story!</h6><p class="util-bar-flyout-subtitle util-bar-flyout-subtitle-share">Let friends in your social network know what you are reading about</p></div><div class="util-bar-flyout-nav util-bar-flyout-nav-share"><span class="util-bar-flyout-nav-btn-wrap"><span
                                    class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-facebook active"
                                    data-share-method="facebook"
                                    data-uotrack="UtilityBarFlyoutFacebookBtn"
                                >Facebook</span></span><span class="util-bar-flyout-nav-btn-wrap"><span
                                        class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-email"
                                        data-share-method="email"
                                        data-uotrack="UtilityBarFlyoutEmailBtn"
                                    >Email</span></span><span class="util-bar-flyout-nav-btn-wrap"><a
                                    class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-twitter"
                                    data-share-method="twitter"
                                    data-popup-width="550"
                                    data-popup-height="450"
                                    data-uotrack="UtilityBarFlyoutTwitterLink"
                                    href="https://twitter.com/intent/tweet?url=https%3A//www.daily-times.com/story/news/local/2020/05/11/donation-drive-continues-through-may-16-san-juan-college-campus/3101186001/&amp;text=San%20Juan%20College%20still%20seeking%20donations%20for%20Navajo%20Nation%20amid%20COVID-19%20crisis&amp;via=TheDailyTimes"
                                    target="_blank" data-popup
                                >Twitter</a></span><span class="util-bar-flyout-nav-btn-wrap"><a
                                    class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-googleplus"
                                    data-share-method="googleplus"
                                    data-popup-width="500"
                                    data-popup-height="500"
                                    data-uotrack="UtilityBarFlyoutGooglePlusLink"
                                    href="//plus.google.com/share?url=https%3A//www.daily-times.com/story/news/local/2020/05/11/donation-drive-continues-through-may-16-san-juan-college-campus/3101186001/"
                                    target="_blank" data-popup
                                >Google+</a></span><span class="util-bar-flyout-nav-btn-wrap"><a
                                    class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-linkedin"
                                    data-share-method="linkedin"
                                    data-popup-width="600"
                                    data-popup-height="455"
                                    data-uotrack="UtilityBarFlyoutLinkedInLink"
                                    href="http://www.linkedin.com/shareArticle?url=https%3A//www.daily-times.com/story/news/local/2020/05/11/donation-drive-continues-through-may-16-san-juan-college-campus/3101186001/&amp;mini=true"
                                    target="_blank" data-popup
                                >LinkedIn</a></span><span class="util-bar-flyout-nav-btn-wrap"><a
                                        href="//www.pinterest.com/pin/create/button/?url=https%3A//www.daily-times.com/story/news/local/2020/05/11/donation-drive-continues-through-may-16-san-juan-college-campus/3101186001/&media=https://www.gannett-cdn.com/presto/2020/05/08/PNM7/1be7a91f-36c2-4dea-82a8-f643f8ae53cd-0P1A9208.JPG?crop=3531,1986,x1,y186&width=3200&height=1680&fit=bounds&description=Donors are asked to bring nonperishable food, bottled water, cleaning supplies and pet food to the San Juan College campus in Farmington."
                                        data-pin-do="buttonPin"
                                        data-pin-config="above"
                                        class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-pinterest"
                                        data-share-method="pinterest"
                                        data-popup-width="600"
                                        data-popup-height="455"
                                        data-uotrack="UtilityBarFlyoutPinterestLink"
                                        target="_blank" data-popup
                                        >Pinterest</a></span></div><div class="util-bar-share-summary"><img class="util-bar-share-summary-image" height="60" width="60" data-src="https://www.gannett-cdn.com/presto/2020/05/08/PNM7/1be7a91f-36c2-4dea-82a8-f643f8ae53cd-0P1A9208.JPG?crop=2577,2577,x766,y0&width=60&height=60&fit=bounds" alt="" /><h4 class="util-bar-share-summary-title">San Juan College still seeking donations for Navajo Nation amid COVID-19 crisis</h4><p class="util-bar-share-summary-description">Donors are asked to bring nonperishable food, bottled water, cleaning supplies and pet food to the San Juan College campus in Farmington.</p></div><div class="util-bar-flyout-section util-bar-flyout-section-facebook"><form method="post" class="util-bar-share-form-facebook"><div
                                    class="util-bar-share-message-facebook"
                                    data-link="https://www.daily-times.com/story/news/local/2020/05/11/donation-drive-continues-through-may-16-san-juan-college-campus/3101186001/"
                                    data-image="https://www.gannett-cdn.com/presto/2020/05/08/PNM7/1be7a91f-36c2-4dea-82a8-f643f8ae53cd-0P1A9208.JPG?crop=3531,1986,x1,y186&width=3200&height=1680&fit=bounds"
                                    data-title="San Juan College still seeking donations for Navajo Nation amid COVID-19 crisis"></div><div class="util-bar-share-submit-wrap-facebook"><span class="util-bar-share-form-status-facebook"><img class="util-bar-share-loading-facebook" src="https://www.gannett-cdn.com/uxstatic/daily-times/uscp-web-static-4525.35.0/images/indicators/facebook-loading.gif" alt="Loading&hellip;"><span class="util-bar-share-status-text-facebook"></span></span><span class="util-bar-share-submit-btn-facebook">Post to Facebook</span></div></form></div><div class="share-email-container js-share-email-container"><div class="share-email-form-container js-share-email-form-container"><form action="/services/mail/v4/send/" method="post" class="share-email-form js-share-email-form"><input type="hidden" name="email_type" value="share_email" class="share-email-form-input "><input type="hidden" name="share_title" value="San Juan College still seeking donations for Navajo Nation amid COVID-19 crisis" class="share-email-form-input"><input type="text" name="your_name" class="email-to optional share-email-form-input ui-text-input" placeholder="Your Name"><input type="text" name="from" class="email-to required share-email-form-input ui-text-input "
                       placeholder="Your Email"><input type="text" name="to" class="email-from required share-email-form-input ui-text-input "
                       placeholder="Your Friend's Email"><textarea class="email-message share-email-form-textarea js-share-email-form-textarea ui-textarea " name="message"
                          placeholder="Message (optional)">San Juan College still seeking donations for Navajo Nation amid COVID-19 crisis &#13;&#13;Donors are asked to bring nonperishable food, bottled water, cleaning supplies and pet food to the San Juan College campus in Farmington.  &#13;&#13;Check out this story on Daily-Times.com: https://www.daily-times.com/story/news/local/2020/05/11/donation-drive-continues-through-may-16-san-juan-college-campus/3101186001/</textarea><script src="https://www.google.com/recaptcha/api.js" async defer></script><div id="recaptcha-share" data-key="6LcLACIUAAAAAPLABOr22JCXRoTG-_lo3Nl8kFpv"></div><div class="email-form-buttons share-email-form-buttons"><span class="ui-chunky-btn secondary icon cancel share-email-form-cancel-btn js-share-email-cancel-btn">Cancel</span><span class="ui-chunky-btn icon send share-email-form-send-btn js-share-email-send-btn">Send</span></div></form></div><div class="share-email-success-pane js-share-email-form-success-pane"><h4 class="share-email-success-pane-title">Sent!</h4><p class="share-email-success-pane-description">A link has been sent to your friend's email address.</p></div></div></div><div class="util-bar-flyout-pane util-bar-flyout-pane-success util-bar-flyout-pane-success-facebook"><h4 class="util-bar-success-title util-bar-success-title-facebook">Posted!</h4><p class="util-bar-success-description util-bar-success-description-facebook">A link has been posted to your Facebook feed. </p></div><div class="util-bar-flyout-close-ribbon"></div></div></div><div class="util-bar-module util-bar-module-comments"><div
                        class="util-bar-btn util-bar-btn-comments"
                        data-uotrack="UtilityBarCommentsBtn"
                        data-module-name="utility-bar-module-comments"></div><div class="util-bar-flyout util-bar-flyout-comments"><div class="util-bar-flyout-heading util-bar-flyout-heading-comments hidden"><h6 class="util-bar-flyout-title util-bar-flyout-title-comments">Join the Conversation</h6><p class="util-bar-flyout-subtitle util-bar-flyout-subtitle-comments">To find out more about Facebook commenting please read the <a href="http://static.daily-times.com/conversation-guidelines/">Conversation Guidelines and FAQs</a></p></div><div class="util-bar-comments-wrap"><div class="util-bar-scroll-wrap util-bar-scroll-wrap-comments"><div class="facebook-comments-plugin-wrap scrollable-content hidden"><div class="fb-comments" data-href="https://www.daily-times.com/story/news/local/2020/05/11/donation-drive-continues-through-may-16-san-juan-college-campus/3101186001/" data-posts="20" data-width="400"></div></div><div class="coral-talk-comments-plugin-wrap scrollable-content hidden"><div class="coral-talk-header"><h2 class="coral-talk-title">Comments</h2><p class="coral-talk-message">
                                            Welcome to our new and improved comments<span class="coral-talk-subscribers-only hidden">, which are for subscribers only</span>.
                                            This is a test to see whether we can improve the experience for you.
                                            You do not need a Facebook profile to participate.
                                        </p><p class="coral-talk-message">
                                            You will need to register before adding a comment.
                                            Typed comments will be lost if you are not logged in.
                                        </p><p class="coral-talk-message">
                                            Please be polite.
                                            It's OK to disagree with someone's ideas, but personal attacks, insults, threats, hate speech, advocating violence and other violations can result in a ban.
                                            If you see comments in violation of our <a class="coral-talk-header-link" href="//static.daily-times.com/conversation-guidelines/" data-track-label="exit|commentscommunityrules">community guidelines</a>, please report them.
                                        </p></div><div class="coral-talk-embed-wrap"></div><iframe class="gup-embed hidden"></iframe></div></div></div><div class="util-bar-flyout-close-ribbon"></div></div></div></div><div class="util-bar-secondary-modules"><div class="util-bar-module util-bar-module-print"><div
                        class="util-bar-btn util-bar-btn-print"
                        data-uotrack="UtilityBarPrintBtn"
                        data-module-name="utility-bar-module-print"></div></div></div></div></div><section id="module-position-SsqYdPlJPxQ" class="storytopbar-bucket asset-nav-bar-module story-asset-nav-bar-module"></section><section id="module-position-SsqYdPk9RKU" class="storytopbar-bucket story-headline-module story-story-headline-module"><h1 class="asset-headline speakable-headline" itemprop="headline">San Juan College still seeking donations for Navajo Nation amid COVID-19 crisis</h1></section><section id="module-position-SsqYdPlDjDM" class="storytopbar-bucket priority-asset-module story-priority-asset-module"></section><section id="module-position-SsqYdPlea3g" class="storytopbar-bucket story-byline-module story-story-byline-module"><div class="asset-metabar"><span class="asset-metabar-author asset-metabar-item" data-track-label="article|news:local|authorbyline">Mike Easterling, Farmington Daily Times</span><span class="asset-metabar-time asset-metabar-item nobyline">
            Published 6:11 p.m. MT May 10, 2020
        </span></div></section><section id="module-position-SsqYdPlscEw" class="storytopbar-bucket piano-module story-piano-module"></section><section id="module-position-SsqYdPkMAfg" class="storytopbar-bucket bounce-exchange-module story-bounce-exchange-module"></section><section id="module-position-SsqYdPkt1r8" class="storytopbar-bucket google-survey-module story-google-survey-module"></section><!-- p402_premium class is utilized by Google Consumer Surveys --><div class="asset-double-wide double-wide p402_premium" role="main" itemprop="mainEntity articleBody"><div id="module-position-SsqYdXxWS7c" class="story-asset video-asset"><div class="ui-video-wrapper " itemprop="video" itemscope itemtype="http://schema.org/VideoObject" ><script src="https://www.gannett-cdn.com/gannett-web/apps/teal/dist/vendor/hls/hls.light.0.12.4.min.require.js" async></script><script src="https://imasdk.googleapis.com/js/sdkloader/ima3.js" async></script><script src="https://www.gannett-cdn.com/gannett-web/apps/teal/dist/vendor/ias/ias-3.5.1.min.js" async></script><script src="https://www.gannett-cdn.com/gannett-web/apps/teal/dist/vendor/adobe/MediaSDK.2.2.0.min.require.js" async></script><script src="https://www.gannett-cdn.com/gannett-web/apps/teal/dist/vendor/comscore/streamsense-5.1.1.160316.min.js" async></script><script src="https://www.gannett-cdn.com/gannett-web/apps/teal/dist/vendor/chartbeat/chartbeat_video-1.0.0.min.js" async></script><div class="story-video js-video-avp automatedvideoplayerhidden automatedvideoplayer ui-teal-video js-teal-player js-ui-video-init"><div class="teal-video-wrap"><video
                        playsinline
                        poster="https://www.gannett-cdn.com/presto/2020/05/07/USAT/b0578556-e488-4535-8ac4-643d460011e7-16x9-2.jpg?width=400" style="width: 400px; height: 225px;"></video><div class="tealplayer-ad-container"></div></div><div class="js-ptb pluto-title-bar"><div class="pluto-title-bar-vcenter pluto-title-bar-text"></div><div class="js-ptb-close pluto-title-bar-vcenter pluto-title-bar-close"><div>CLOSE<img class="pluto-title-bar-close-icon" src="https://www.gannett-cdn.com/uxstatic/daily-times/uscp-web-static-4525.35.0/images/sprites/icon_close.png"></div></div></div><script type='json/data' class='ui-video-data'>{"origin": "USA TODAY", "gannettTracking": "3089333001", "videoStillURL": "https://www.gannett-cdn.com/presto/2020/05/07/USAT/b0578556-e488-4535-8ac4-643d460011e7-16x9-2.jpg", "short_url": "https://www.usatoday.com/videos/life/humankind/2020/05/07/nurses-run-glee-towards-gift-nyc-sanitation-worker/3089333001/", "contentSourceCode": "USAT", "keywords": "Wine,Nurses,Video Syndication - USAT,Video Syndication \u2013 International", "taxonomyEntities": [{"id": "67bbd95f-1779-407e-b019-0527a5283b9b"}, {"id": "353b0895-952e-44ce-bbb3-c40a8e3c320f"}, {"id": "6f55135f-3b5e-490d-8a52-a3b8e1f11ee7"}, {"id": "abb1b69c-143a-47e0-9004-50120aa6b80d"}], "id": 3089333001, "adsEnabled": true, "AVPplayer": true, "mobile_url": "https://www.usatoday.com/videos/life/humankind/2020/05/07/nurses-run-glee-towards-gift-nyc-sanitation-worker/3089333001/", "byline": "Humankind", "hlsURL": "https://hlsmedia.gannett-cdn.com/authoring/video-renditions/2c21fd5f-4edd-4d3d-9a17-8e9da66788e3/83c9d67e-f41f-47f7-8ac3-3d6a435f0b36/1080p_30fps,720p_30fps,480p_30fps,master.m3u8", "asset_metadata": {"items": {"origin": "USA TODAY", "attribution": "Humankind", "awspath": "lifestyle/humankind", "credit": "Humankind, USA Today", "keywords": "Wine,Nurses,Video Syndication - USAT,Video Syndication \u2013 International", "shortdescription": "New York Sanitation Deputy Chief James McGovern greeted several nurses with a free happy hour after they finished their shifts at Elmhurst Hospital in Queens, New York.", "adsEnabled": true}}, "title": "Nurses run with glee towards gift from NYC sanitation worker", "headline": "Nurses run with glee towards gift from NYC sanitation worker", "ssts": {"leafName": "humankind", "section": "life", "topic": "", "subsection": "humankind", "storysubject": "", "path": "life/humankind", "taxonomyEntityDisplayName": "Humankind", "subtopic": ""}, "createDate": "2020-05-07T17:28:02.837Z", "pageURL": {"short": "https://www.usatoday.com/videos/life/humankind/2020/05/07/nurses-run-glee-towards-gift-nyc-sanitation-worker/3089333001/", "long": "https://www.usatoday.com/videos/life/humankind/2020/05/07/nurses-run-glee-towards-gift-nyc-sanitation-worker/3089333001/"}, "type": "video", "thumbnail": "https://www.gannett-cdn.com/presto/2020/05/07/USAT/b0578556-e488-4535-8ac4-643d460011e7-16x9-2.jpg?width=388&height=388&crop=1080,1080,x420,y0", "status": "published", "tags": [{"id": "67bbd95f-1779-407e-b019-0527a5283b9b"}, {"id": "353b0895-952e-44ce-bbb3-c40a8e3c320f"}, {"id": "6f55135f-3b5e-490d-8a52-a3b8e1f11ee7"}, {"id": "abb1b69c-143a-47e0-9004-50120aa6b80d"}], "credit": "USA TODAY", "publishDate": "2020-05-07T17:36:44.652Z", "geoTag": {"id": ""}, "initialPublishDate": "2020-05-07T17:34:03.615Z", "siteId": 1, "thumbnailURL": "https://www.gannett-cdn.com/presto/2020/05/07/USAT/b0578556-e488-4535-8ac4-643d460011e7-16x9-2.jpg?width=388&height=388&crop=1080,1080,x420,y0", "videoStill": "https://www.gannett-cdn.com/presto/2020/05/07/USAT/b0578556-e488-4535-8ac4-643d460011e7-16x9-2.jpg", "promoBrief": "New York Sanitation Deputy Chief James McGovern greeted several nurses with a free happy hour after they finished their shifts at Elmhurst Hospital in Queens, New York.", "name": "video", "renditions": {"duration": 34000}, "awspath": "lifestyle/humankind", "large": false, "still_url": "https://www.gannett-cdn.com/presto/2020/05/07/USAT/b0578556-e488-4535-8ac4-643d460011e7-16x9-2.jpg", "length": 34, "position": 0, "asset_document": "", "assetGroup": {"sstsId": "", "url": "", "siteId": 1, "id": 1, "name": "USATODAY"}, "shortdescription": "New York Sanitation Deputy Chief James McGovern greeted several nurses with a free happy hour after they finished their shifts at Elmhurst Hospital in Queens, New York.", "mp4URL": "https://downloadmedia.gannett-cdn.com/authoring/video-renditions/2c21fd5f-4edd-4d3d-9a17-8e9da66788e3/83c9d67e-f41f-47f7-8ac3-3d6a435f0b36/1080p_30fps.mp4", "page_url": "https://www.usatoday.com/videos/life/humankind/2020/05/07/nurses-run-glee-towards-gift-nyc-sanitation-worker/3089333001/"}</script><script type='json/data' class='ui-video-placement-data'>{"apsEnabled": true, "hls": {"excludeRenditions": true}, "enableLogging": true, "height": 225, "analyticsEnabled": true, "enableTealPlayer": true, "scrollingplayer": false, "enableSnowPlayer": false, "disableDescription": true, "ads": true, "width": 400, "enable": true, "share": true, "unlimitedAds": {"requiredPlays": 0, "enabled": true}, "uwConfigParams": "&pagetype=story", "name": "automatedvideoplayer", "enableUwPlayer": false, "uwAutoplay": true, "mutedAutoplay": true, "gannett_continuous_endslate": true, "mediatemplate": false, "embed": true, "autoplay": true}</script></div><div class="ui-video-controls story-video js-video-avp automatedvideoplayerhidden" style="width: 400px;"><meta itemprop="description" content="New York Sanitation Deputy Chief James McGovern greeted several nurses with a free happy hour after they finished their shifts at Elmhurst Hospital in Queens, New York." /></div></div></div><div id="module-position-SsqYdXydj0Q" class="story-asset gallery-asset"><div class="card-film inactive"></div><div class="sidebar-gallery-btn active"></div><div class="companion-story-gallery js-llc" data-name="compStoryGallery"><div class="gallery-sidebar-panel has-leaderboard"><span class="gallery-sidebar-close"></span><div class="gallery-sidebar-toolbox share-pane social-pane "><span class="util-bar-flyout-nav-btn-wrap"><span
            class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-facebook gallery-util-bar-flyout-nav-btn"
            href="#"
            target="_blank"
            data-share-link="https://www.daily-times.com/picture-gallery/news/local/2020/05/11/san-juan-college-collects-supplies-navajo-nation-residents-coronavirus/3101017001/"
            data-share-title=""
            data-share-method="facebook"
            data-uotrack="UtilityBarFlyoutFacebookBtn"
        >Facebook</span></span><span class="util-bar-flyout-nav-btn-wrap"><a
            class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-twitter gallery-util-bar-flyout-nav-btn"
            data-share-method="twitter"
            data-popup-width="550"
            data-popup-height="450"
            data-uotrack="UtilityBarFlyoutTwitterLink"
            href="https://twitter.com/intent/tweet?url=https://www.daily-times.com/picture-gallery/news/local/2020/05/11/san-juan-college-collects-supplies-navajo-nation-residents-coronavirus/3101017001/&amp;text=San%20Juan%20College%20still%20seeking%20donations%20for%20Navajo%20Nation%20amid%20COVID-19%20crisis&amp;via=TheDailyTimes"
            target="_popup"
        >Twitter</a></span><span class="util-bar-flyout-nav-btn-wrap"><a
            class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-googleplus gallery-util-bar-flyout-nav-btn"
            data-share-method="googleplus"
            data-popup-width="500"
            data-popup-height="500"
            data-uotrack="UtilityBarFlyoutGooglePlusLink"
            href="//plus.google.com/share?url=https://www.daily-times.com/picture-gallery/news/local/2020/05/11/san-juan-college-collects-supplies-navajo-nation-residents-coronavirus/3101017001/"
            target="_popup"
        >Google+</a></span><span class="util-bar-flyout-nav-btn-wrap"><a
            class="util-bar-flyout-nav-btn util-bar-flyout-nav-btn-linkedin gallery-util-bar-flyout-nav-btn"
            data-share-method="linkedin"
            data-popup-width="1000"
            data-popup-height="455"
            data-uotrack="UtilityBarFlyoutLinkedInLink"
            href="http://www.linkedin.com/shareArticle?url=https://www.daily-times.com/picture-gallery/news/local/2020/05/11/san-juan-college-collects-supplies-navajo-nation-residents-coronavirus/3101017001/&mini=true"
            target="_popup"
        >LinkedIn</a></span></div><div class="title gallery-sidebar-title selected">San Juan College collects supplies for Navajo Nation residents amid coro...</div><div class="gallery-sidebar-fullscreen"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen">&nbsp;</span>Fullscreen</a></div><div class="caption"></div><div class="gallery-sidebar-flyout-section util-bar-flyout-section util-bar-flyout-section-facebook"><form method="post" class="util-bar-share-form-facebook"><div
            class="util-bar-share-message-facebook"
            data-link="https://www.daily-times.com/picture-gallery/news/local/2020/05/11/san-juan-college-collects-supplies-navajo-nation-residents-coronavirus/3101017001/"
            data-title="San Juan College still seeking donations for Navajo Nation amid COVID-19 crisis"
            placeholder="Message (optional)"></div><div class="util-bar-share-submit-wrap-facebook"><span class="util-bar-share-form-status-facebook"><img class="util-bar-share-loading-facebook" src="https://www.gannett-cdn.com/uxstatic/daily-times/uscp-web-static-4525.35.0/images/indicators/facebook-loading.gif"><span class="util-bar-share-status-text-facebook"></span></span><span class="util-bar-share-submit-btn-facebook">Post to Facebook</span></div></form></div><div class="util-bar-flyout-pane util-bar-flyout-pane-success util-bar-flyout-pane-success-facebook"><h4 class="util-bar-success-title util-bar-success-title-facebook">Posted!</h4><p class="util-bar-success-description util-bar-success-description-facebook">A link has been posted to your Facebook feed. </p></div><div class="companion-galleries-partner-slot"></div></div><div class="companion-galleries embedded_story hasendslate galleries"
        data-gallery-id="3101017001"
        data-title="San Juan College collects supplies for Navajo Nation residents"
        data-seo-title="San Juan College collects supplies for Navajo Nation residents"
        data-ssts="news/local"
        data-cst="news/local/communities_sanjuan"
        data-published-date="2020-05-11T00:11:01.834Z"
        
        
         data-gal-pageurl="https://www.daily-times.com/picture-gallery/news/local/2020/05/11/san-juan-college-collects-supplies-navajo-nation-residents-coronavirus/3101017001/"><div class="viewport gallery-viewport"><div class="slide gallery-viewport-slide  active"  itemprop="primaryImageOfPage"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo  gallery-photo-first" data-mycapture-src="" data-mycapture-sm-src=""
                                
                                    data-src="https://www.gannett-cdn.com/presto/2020/05/08/PNM7/2550115e-03fd-41e0-b8e8-f3a8e55120bc-0P1A9166.JPG?width=520&amp;height=390&amp;fit=bounds&amp;auto=webp"
                                    data-large-src="https://www.gannett-cdn.com/presto/2020/05/08/PNM7/2550115e-03fd-41e0-b8e8-f3a8e55120bc-0P1A9166.JPG?width=1920&amp;height=1440&amp;fit=bounds&amp;auto=webp"
                                
                                alt="Volunteers Laura Darrow, left, and Shirley Hoskie, both employees of the San Juan College physical plant, post a sign May 8 on the college campus alerting drivers of the drop-off site for donations for Navajo Nation people affected by the COVID-19 shutdown." data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="292" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption gallery-viewport-caption-no-mycapture"><span class="js-caption">Volunteers Laura Darrow, left, and Shirley Hoskie, both employees of the San Juan College physical plant, post a sign May 8 on the college campus alerting drivers of the drop-off site for donations for Navajo Nation people affected by the COVID-19 shutdown.</span><meta itemprop="copyrightHolder" content="Mike Easterling/The Daily Times" /><span class="credit gallery-viewport-credit"> Mike Easterling/The Daily Times</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide "  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo " data-mycapture-src="" data-mycapture-sm-src=""
                                
                                    data-src="https://www.gannett-cdn.com/presto/2020/05/08/PNM7/96eee323-8993-4cd1-a050-067e82ce5c2d-0P1A9189.JPG?width=520&amp;height=390&amp;fit=bounds&amp;auto=webp"
                                    data-large-src="https://www.gannett-cdn.com/presto/2020/05/08/PNM7/96eee323-8993-4cd1-a050-067e82ce5c2d-0P1A9189.JPG?width=1920&amp;height=1440&amp;fit=bounds&amp;auto=webp"
                                
                                alt="Volunteer Ethan Sullivan hands a bag of goods to his mother, San Juan College English professor Danielle Sullivan, on May 8 during a donation drive for people on the Navajo Nation who need help during the COVID-19 shutdown." data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="292" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption gallery-viewport-caption-no-mycapture"><span class="js-caption">Volunteer Ethan Sullivan hands a bag of goods to his mother, San Juan College English professor Danielle Sullivan, on May 8 during a donation drive for people on the Navajo Nation who need help during the COVID-19 shutdown.</span><meta itemprop="copyrightHolder" content="Mike Easterling/The Daily Times" /><span class="credit gallery-viewport-credit"> Mike Easterling/The Daily Times</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide "  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo " data-mycapture-src="" data-mycapture-sm-src=""
                                
                                    data-src="https://www.gannett-cdn.com/presto/2020/05/08/PNM7/1be7a91f-36c2-4dea-82a8-f643f8ae53cd-0P1A9208.JPG?width=520&amp;height=390&amp;fit=bounds&amp;auto=webp"
                                    data-large-src="https://www.gannett-cdn.com/presto/2020/05/08/PNM7/1be7a91f-36c2-4dea-82a8-f643f8ae53cd-0P1A9208.JPG?width=1920&amp;height=1440&amp;fit=bounds&amp;auto=webp"
                                
                                alt="Shirley Hoskie, the operations coordinator for the San Juan College physical plant, prepares to unload a trunkful of goods May 8 on the college campus during a donation drive for people on the Navajo Nation struggling from the COVID-19 shutdown." data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="292" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption gallery-viewport-caption-no-mycapture"><span class="js-caption">Shirley Hoskie, the operations coordinator for the San Juan College physical plant, prepares to unload a trunkful of goods May 8 on the college campus during a donation drive for people on the Navajo Nation struggling from the COVID-19 shutdown.</span><meta itemprop="copyrightHolder" content="Mike Easterling/The Daily Times" /><span class="credit gallery-viewport-credit"> Mike Easterling/The Daily Times</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide "  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo " data-mycapture-src="" data-mycapture-sm-src=""
                                
                                    data-src="https://www.gannett-cdn.com/presto/2020/05/08/PNM7/cc83284f-c204-45c3-ac55-c8004f57c700-0P1A9216.JPG?width=520&amp;height=390&amp;fit=bounds&amp;auto=webp"
                                    data-large-src="https://www.gannett-cdn.com/presto/2020/05/08/PNM7/cc83284f-c204-45c3-ac55-c8004f57c700-0P1A9216.JPG?width=1920&amp;height=1440&amp;fit=bounds&amp;auto=webp"
                                
                                alt="San Juan College English professor Danielle Sullivan retrieves a package of paper towels from the trunk of a car May 8 on the college campus during a donation drive for people on the Navajo Nation who are struggling because of the COVID-19 shutdown." data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="292" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption gallery-viewport-caption-no-mycapture"><span class="js-caption">San Juan College English professor Danielle Sullivan retrieves a package of paper towels from the trunk of a car May 8 on the college campus during a donation drive for people on the Navajo Nation who are struggling because of the COVID-19 shutdown.</span><meta itemprop="copyrightHolder" content="Mike Easterling/The Daily Times" /><span class="credit gallery-viewport-credit"> Mike Easterling/The Daily Times</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide "  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo " data-mycapture-src="" data-mycapture-sm-src=""
                                
                                    data-src="https://www.gannett-cdn.com/presto/2020/05/08/PNM7/f21fa565-dd77-49d0-b652-dbc6b7cad8e9-0P1A9242.JPG?width=520&amp;height=390&amp;fit=bounds&amp;auto=webp"
                                    data-large-src="https://www.gannett-cdn.com/presto/2020/05/08/PNM7/f21fa565-dd77-49d0-b652-dbc6b7cad8e9-0P1A9242.JPG?width=1920&amp;height=1440&amp;fit=bounds&amp;auto=webp"
                                
                                alt="Volunteers Ethan Sullivan and San Juan College professor Sherri Cummins move goods to the front of a semi-trailer on May 8 on the college campus during a donation drive for people on the Navajo Nation impacted by the COVID-19 shutdown." data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="292" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption gallery-viewport-caption-no-mycapture"><span class="js-caption">Volunteers Ethan Sullivan and San Juan College professor Sherri Cummins move goods to the front of a semi-trailer on May 8 on the college campus during a donation drive for people on the Navajo Nation impacted by the COVID-19 shutdown.</span><meta itemprop="copyrightHolder" content="Mike Easterling/The Daily Times" /><span class="credit gallery-viewport-credit"> Mike Easterling/The Daily Times</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide "  itemprop="associatedMedia"  itemscope itemtype="http://schema.org/ImageObject"><div class="gallery-photo-border"><img itemprop="image" class="gallery-photo " data-mycapture-src="" data-mycapture-sm-src=""
                                
                                    data-src="https://www.gannett-cdn.com/presto/2020/05/08/PNM7/6518bddd-96b7-4c3f-8676-593bf66f0b22-0P1A9222.JPG?width=520&amp;height=390&amp;fit=bounds&amp;auto=webp"
                                    data-large-src="https://www.gannett-cdn.com/presto/2020/05/08/PNM7/6518bddd-96b7-4c3f-8676-593bf66f0b22-0P1A9222.JPG?width=1920&amp;height=1440&amp;fit=bounds&amp;auto=webp"
                                
                                alt="Volunteer Ethan Sullivan removes a case of bottled water from the back of a vehicle May 8 on the San Juan College campus during a donation drive seeking household supplies for people on the Navajo Nation struggling because of the COVID-19 shutdown." data-id=""><meta itemprop="height" content="390" /><meta itemprop="width" content="292" /><div class="buy-photo-btn"></div><div class="gallery-viewport-meta meta"><div itemprop="caption" class="caption gallery-viewport-caption gallery-viewport-caption-no-mycapture"><span class="js-caption">Volunteer Ethan Sullivan removes a case of bottled water from the back of a vehicle May 8 on the San Juan College campus during a donation drive seeking household supplies for people on the Navajo Nation struggling because of the COVID-19 shutdown.</span><meta itemprop="copyrightHolder" content="Mike Easterling/The Daily Times" /><span class="credit gallery-viewport-credit"> Mike Easterling/The Daily Times</span></div><div class="toolbox gallery-viewport-toolbox"><a href="#" title="Fullscreen" class="fullscreen gallery-viewport-fullscreen-link"><span class="meta-fullscreen"></span>Fullscreen</a></div></div></div></div><div class="slide gallery-viewport-slide endslate"><div class="gallery-photo-border"><div class="gallery-endslate"><!-- HTML for the endslate content card --><h3 class="gallery-endslate-header">Interested in this topic? You may also want to view these photo galleries:</h3><ul class="gallery-endslate-related"  data-media-url="https://www.gannett-cdn.com/media/"></ul><div class="gallery-endslate-actions"><div class="gallery-actions-replay">Replay</div></div></div></div></div></div><div class="gallery-thumbs thumbs" data-name="compGalleryThumbs"><div class="thumbswrapper"><ul class="thumbslist scrollable-content"><li class="thumb-item active"><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/presto/2020/05/08/PNM7/2550115e-03fd-41e0-b8e8-f3a8e55120bc-0P1A9166.JPG?crop=3647,2735,x0,y206&amp;width=80&amp;height=60&amp;fit=bounds" alt="Volunteers Laura Darrow, left, and Shirley Hoskie, both employees of the San Juan College physical plant, post a sign May 8 on the college campus alerting drivers of the drop-off site for donations for Navajo Nation people affected by the COVID-19 shutdown." width="80" height="60"><span class="thumb-count">1 of 6</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/presto/2020/05/08/PNM7/96eee323-8993-4cd1-a050-067e82ce5c2d-0P1A9189.JPG?crop=2660,1995,x0,y266&amp;width=80&amp;height=60&amp;fit=bounds" alt="Volunteer Ethan Sullivan hands a bag of goods to his mother, San Juan College English professor Danielle Sullivan, on May 8 during a donation drive for people on the Navajo Nation who need help during the COVID-19 shutdown." width="80" height="60"><span class="thumb-count">2 of 6</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/presto/2020/05/08/PNM7/1be7a91f-36c2-4dea-82a8-f643f8ae53cd-0P1A9208.JPG?crop=3427,2570,x104,y0&amp;width=80&amp;height=60&amp;fit=bounds" alt="Shirley Hoskie, the operations coordinator for the San Juan College physical plant, prepares to unload a trunkful of goods May 8 on the college campus during a donation drive for people on the Navajo Nation struggling from the COVID-19 shutdown." width="80" height="60"><span class="thumb-count">3 of 6</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/presto/2020/05/08/PNM7/cc83284f-c204-45c3-ac55-c8004f57c700-0P1A9216.JPG?crop=4851,3638,x133,y8&amp;width=80&amp;height=60&amp;fit=bounds" alt="San Juan College English professor Danielle Sullivan retrieves a package of paper towels from the trunk of a car May 8 on the college campus during a donation drive for people on the Navajo Nation who are struggling because of the COVID-19 shutdown." width="80" height="60"><span class="thumb-count">4 of 6</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/presto/2020/05/08/PNM7/f21fa565-dd77-49d0-b652-dbc6b7cad8e9-0P1A9242.JPG?crop=3647,2735,x0,y1094&amp;width=80&amp;height=60&amp;fit=bounds" alt="Volunteers Ethan Sullivan and San Juan College professor Sherri Cummins move goods to the front of a semi-trailer on May 8 on the college campus during a donation drive for people on the Navajo Nation impacted by the COVID-19 shutdown." width="80" height="60"><span class="thumb-count">5 of 6</span></div></a></li><li class="thumb-item "><a href="#" class='thumb-link'><div class="thumb-image-border"><img class="thumb-image" data-src="https://www.gannett-cdn.com/presto/2020/05/08/PNM7/6518bddd-96b7-4c3f-8676-593bf66f0b22-0P1A9222.JPG?crop=3647,2735,x0,y820&amp;width=80&amp;height=60&amp;fit=bounds" alt="Volunteer Ethan Sullivan removes a case of bottled water from the back of a vehicle May 8 on the San Juan College campus during a donation drive seeking household supplies for people on the Navajo Nation struggling because of the COVID-19 shutdown." width="80" height="60"><span class="thumb-count">6 of 6</span></div></a></li></ul></div></div><div class="feature-btns"><div class="ticker feature-btns-control"></div><div class="autoplay feature-btns-control"><span class="playbtn feature-btns-label">Autoplay</span></div><div class="thumbnails feature-btns-control"><span class="thumbLabel feature-btns-label">Show Thumbnails</span></div><div class="captions feature-btns-control"><span class="captionLabel feature-btns-label">Show Captions</span></div></div><a class="slide-nav prev gallery-prev" rel="prev">Last Slide</a><a class="slide-nav next gallery-next" rel="next">Next Slide</a></div><div class="gallery-leaderboard-ad"><div class="partner-placement leaderboard-companion-ad" data-ad-placement="leaderboard_atf" data-ad-sizes="[[728,90]]"></div></div></div></div><div id="module-position-SsqYdXyGluE" class="story-asset story-leadin-asset"><h2 class="lead-in">Donation drive will continue on campus through May 16</h2></div><div id="module-position-SsqYdXzCwrg" class="story-asset story-metadata-asset"></div><div id="module-position-SsqYdXyFQ2M" class="story-asset inline-share-tools-asset"><div class="inline-share-tools asset-inline-share-tools asset-inline-share-tools-top"><span
        class="inline-share-btn inline-share-btn-facebook"
        data-share-method="facebook"
        data-uotrack="InlineShareFacebookBtn"><span class="inline-share-count inline-share-count-facebook"></span><span class="inline-share-btn-label inline-share-btn-label-facebook">CONNECT</span></span><a
        class="inline-share-btn inline-share-btn-twitter"
        data-share-method="twitter"
        data-uotrack="InlineShareTwitterLink"
        data-popup-width="550"
        data-popup-height="450"
        href="https://twitter.com/intent/tweet?url=https%3A//www.daily-times.com/story/news/local/2020/05/11/donation-drive-continues-through-may-16-san-juan-college-campus/3101186001/&amp;text=San%20Juan%20College%20still%20seeking%20donations%20for%20Navajo%20Nation%20amid%20COVID-19%20crisis&amp;via=TheDailyTimes"
        target="_blank" data-popup
        rel="nofollow"><span class="inline-share-count inline-share-count-twitter"></span><span class="inline-share-btn-label inline-share-btn-label-twitter">TWEET</span></a><a
        class="inline-share-btn inline-share-btn-linkedin"
        data-share-method="linkedin"
        data-popup-width="600"
        data-popup-height="455"
        data-uotrack="UtilityBarFlyoutLinkedInLink"
        href="http://www.linkedin.com/shareArticle?url=https%3A//www.daily-times.com/story/news/local/2020/05/11/donation-drive-continues-through-may-16-san-juan-college-campus/3101186001/&amp;mini=true"
        target="_blank" data-popup
        rel="nofollow"><span class="inline-share-count inline-share-count-linkedin"></span><span class="inline-share-btn-label inline-share-btn-label-linkedin">LINKEDIN</span></a><span
            class="inline-share-btn inline-share-btn-comments"
            data-share-method="comments"
            data-uotrack="InlineShareCommentsBtn"><span class="inline-share-count inline-share-count-comments"></span><span class="inline-share-btn-label inline-share-btn-label-comments">COMMENT</span></span><span
        class="inline-share-btn inline-share-btn-email"
        data-share-method="email"
        data-uotrack="InlineShareEmailBtn"><span class="inline-share-count inline-share-count-email"></span><span class="inline-share-btn-label inline-share-btn-label-email">EMAIL</span></span><span
         class="inline-share-btn inline-share-btn-more"
         data-share-method="facebook"
         data-uotrack="InlineShareMoreBtn"><span class="inline-share-count inline-share-count-more"></span><span class="inline-share-btn-label inline-share-btn-label-more">MORE</span></span></div></div><p class="speakable-p-1 p-text">FARMINGTON — A donation drive seeking household goods, groceries and pet food for people on the Navajo Nation who have been negatively impacted by the COVID-19 shutdown got underway May 8 on the San Juan College campus and will continue the rest of this week.</p><p class="speakable-p-2 p-text">Drive organizer Danielle Sullivan, an associate professor of English at the college, was joined by a handful of volunteers who loaded the supplies into the school's semi-trailer after they were removed from the vehicles of donors who drove them to the drop-off site between the West Classroom Complex and the Henderson Fine Arts Center.</p><p class="p-text">The drive got underway at 3 p.m. May 8, and Sullivan said there were a couple of cars already waiting for volunteers when they arrived at the site. By 4 p.m. that day, approximately a dozen drivers had stopped by donate nonperishable food items, toilet paper, paper towels, bottled water and pet food.</p><div id="module-position-SsqYdXz5chQ" class="story-asset image-asset"><aside itemprop="associatedMedia" itemscope itemtype="http://schema.org/ImageObject" class="wide single-photo"><img itemprop="url" src="https://www.gannett-cdn.com/presto/2020/05/08/PNM7/1be7a91f-36c2-4dea-82a8-f643f8ae53cd-0P1A9208.JPG?width=540&amp;height=&amp;fit=bounds&amp;auto=webp" alt="Shirley Hoskie, the operations coordinator for the San Juan College physical plant, prepares to unload a trunkful of goods May 8 on the college campus during a donation drive for people on the Navajo Nation struggling from the COVID-19 shutdown." width="540" data-mycapture-src="https://www.gannett-cdn.com/presto/2020/05/08/PNM7/1be7a91f-36c2-4dea-82a8-f643f8ae53cd-0P1A9208.JPG"
                    data-mycapture-sm-src="https://www.gannett-cdn.com/presto/2020/05/08/PNM7/1be7a91f-36c2-4dea-82a8-f643f8ae53cd-0P1A9208.JPG" /><meta itemprop="name" content="FMN Standalone1 0511" /><meta itemprop="height" content="405" /><meta itemprop="width" content="540" /><span class="mycapture-btn-wrap"><span class="mycapture-non-priority-horizontal-image mycapture-btn-with-text js-mycapture-btn js-mycapture-photo-asset">Buy Photo</span></span><p>Shirley Hoskie, the operations coordinator for the San Juan College physical plant, prepares to unload a trunkful of goods May 8 on the college campus during a donation drive for people on the Navajo Nation struggling from the COVID-19 shutdown.<meta itemprop="copyrightHolder" content="Mike Easterling/The Daily Times" />&nbsp;<span class="credit">(Photo: Mike Easterling/The Daily Times)</span></p></aside><div class="clearfix"></div></div><p class="p-text">"I'm pleasantly surprised," Sullivan said about the response from donors.</p><p class="p-text">The drive will continue for the next several days. Donors may drop the items off at the following times:</p><ul><li>3 p.m. to 6 p.m. May 11 through 14</li><li>1 to 4 p.m. May 15</li><li>10 a.m. to 1 p.m. May 16 </li></ul><p class="p-text">The supplies will be delivered to the Navajo Nation on May 18.</p><p class="p-text">Those wishing to make a monetary donation can do so online by visiting <a data-track-label="inline|intext|n/a" href="http://www.nndoh.org/donate.html" style="background-color: rgb(255, 255, 255);" target="_blank">www.nndoh.org/donate.html</a>.</p><div id="module-position-SsqYdXyXJ1Y" class="story-asset image-asset"><aside itemprop="associatedMedia" itemscope itemtype="http://schema.org/ImageObject" class="single-photo float"><img itemprop="url" src="https://www.gannett-cdn.com/presto/2020/05/08/PNM7/96eee323-8993-4cd1-a050-067e82ce5c2d-0P1A9189.JPG?width=180&amp;height=240&amp;fit=bounds&amp;auto=webp" alt="Volunteer Ethan Sullivan hands a bag of goods to his mother, San Juan College English professor Danielle Sullivan, on May 8 during a donation drive for people on the Navajo Nation who need help during the COVID-19 shutdown." width="180" data-mycapture-src="https://www.gannett-cdn.com/presto/2020/05/08/PNM7/96eee323-8993-4cd1-a050-067e82ce5c2d-0P1A9189.JPG"
                    data-mycapture-sm-src="https://www.gannett-cdn.com/presto/2020/05/08/PNM7/96eee323-8993-4cd1-a050-067e82ce5c2d-0P1A9189.JPG" /><meta itemprop="name" content="FMN Standalone2 0511" /><meta itemprop="height" content="240" /><meta itemprop="width" content="180" /><span class="mycapture-btn-wrap"><span class="mycapture-non-priority-vertical-image mycapture-btn-with-text js-mycapture-btn js-mycapture-photo-asset">Buy Photo</span></span><p>Volunteer Ethan Sullivan hands a bag of goods to his mother, San Juan College English professor Danielle Sullivan, on May 8 during a donation drive for people on the Navajo Nation who need help during the COVID-19 shutdown.<meta itemprop="copyrightHolder" content="Mike Easterling/The Daily Times" />&nbsp;<span class="credit">(Photo: Mike Easterling/The Daily Times)</span></p></aside></div><p class="p-text">The donations are tax deductible, and donors who want one will have their contact information recorded so they can receive a receipt at a later date from the Navajo Nation.</p><p class="p-text">The drop-off point for the drive is designed to be contactless, with volunteers wearing gloves and masks removing the donated items from the back of a donor's vehicle while the donor remains in the vehicle.</p><p class="p-text">Volunteers working on the drive on May 8 quickly were piling up the donated goods in the front of the semi-trailer, but they had a long way to go to fill it. Sullivan issued a plea to those who plan to make a donation later in the week.</p><div id="module-position-SsqYdXzGkyI" class="story-asset image-asset"><aside itemprop="associatedMedia" itemscope itemtype="http://schema.org/ImageObject" class="single-photo float"><img itemprop="url" src="https://www.gannett-cdn.com/presto/2020/05/08/PNM7/2550115e-03fd-41e0-b8e8-f3a8e55120bc-0P1A9166.JPG?width=180&amp;height=240&amp;fit=bounds&amp;auto=webp" alt="Volunteers Laura Darrow, left, and Shirley Hoskie, both employees of the San Juan College physical plant, post a sign May 8 on the college campus alerting drivers of the drop-off site for donations for Navajo Nation people affected by the COVID-19 shutdown." width="180" data-mycapture-src="https://www.gannett-cdn.com/presto/2020/05/08/PNM7/2550115e-03fd-41e0-b8e8-f3a8e55120bc-0P1A9166.JPG"
                    data-mycapture-sm-src="https://www.gannett-cdn.com/presto/2020/05/08/PNM7/2550115e-03fd-41e0-b8e8-f3a8e55120bc-0P1A9166.JPG" /><meta itemprop="name" content="FMN Standalone3 0511" /><meta itemprop="height" content="240" /><meta itemprop="width" content="180" /><span class="mycapture-btn-wrap"><span class="mycapture-non-priority-vertical-image mycapture-btn-with-text js-mycapture-btn js-mycapture-photo-asset">Buy Photo</span></span><p>Volunteers Laura Darrow, left, and Shirley Hoskie, both employees of the San Juan College physical plant, post a sign May 8 on the college campus alerting drivers of the drop-off site for donations for Navajo Nation people affected by the COVID-19 shutdown.<meta itemprop="copyrightHolder" content="Mike Easterling/The Daily Times" />&nbsp;<span class="credit">(Photo: Mike Easterling/The Daily Times)</span></p></aside></div><p class="p-text">"We appreciate delivery in boxes, but we'll take it however we can get it," she said.</p><p class="p-text">Anyone searching for more information about the drive can call TheWantToHelpLine at 505-566-4210.</p><p class="p-text p-text-last" id="article-body-p-last"><em>Mike Easterling can be reached at 505-564-4610 or measterling@daily-times.com.</em></p><div id="module-position-SsqYdXyxGXA" class="story-asset inline-share-tools-asset"><div class="inline-share-tools asset-inline-share-tools asset-inline-share-tools-bottom"><span
        class="inline-share-btn inline-share-btn-facebook"
        data-share-method="facebook"
        data-uotrack="InlineShareFacebookBtn"><span class="inline-share-count inline-share-count-facebook"></span><span class="inline-share-btn-label inline-share-btn-label-facebook">CONNECT</span></span><a
        class="inline-share-btn inline-share-btn-twitter"
        data-share-method="twitter"
        data-uotrack="InlineShareTwitterLink"
        data-popup-width="550"
        data-popup-height="450"
        href="https://twitter.com/intent/tweet?url=https%3A//www.daily-times.com/story/news/local/2020/05/11/donation-drive-continues-through-may-16-san-juan-college-campus/3101186001/&amp;text=San%20Juan%20College%20still%20seeking%20donations%20for%20Navajo%20Nation%20amid%20COVID-19%20crisis&amp;via=TheDailyTimes"
        target="_blank" data-popup
        rel="nofollow"><span class="inline-share-count inline-share-count-twitter"></span><span class="inline-share-btn-label inline-share-btn-label-twitter">TWEET</span></a><a
        class="inline-share-btn inline-share-btn-linkedin"
        data-share-method="linkedin"
        data-popup-width="600"
        data-popup-height="455"
        data-uotrack="UtilityBarFlyoutLinkedInLink"
        href="http://www.linkedin.com/shareArticle?url=https%3A//www.daily-times.com/story/news/local/2020/05/11/donation-drive-continues-through-may-16-san-juan-college-campus/3101186001/&amp;mini=true"
        target="_blank" data-popup
        rel="nofollow"><span class="inline-share-count inline-share-count-linkedin"></span><span class="inline-share-btn-label inline-share-btn-label-linkedin">LINKEDIN</span></a><span
            class="inline-share-btn inline-share-btn-comments"
            data-share-method="comments"
            data-uotrack="InlineShareCommentsBtn"><span class="inline-share-count inline-share-count-comments"></span><span class="inline-share-btn-label inline-share-btn-label-comments">COMMENT</span></span><span
        class="inline-share-btn inline-share-btn-email"
        data-share-method="email"
        data-uotrack="InlineShareEmailBtn"><span class="inline-share-count inline-share-count-email"></span><span class="inline-share-btn-label inline-share-btn-label-email">EMAIL</span></span><span
         class="inline-share-btn inline-share-btn-more"
         data-share-method="facebook"
         data-uotrack="InlineShareMoreBtn"><span class="inline-share-count inline-share-count-more"></span><span class="inline-share-btn-label inline-share-btn-label-more">MORE</span></span></div></div><div class="article-print-url">Read or Share this story: https://www.daily-times.com/story/news/local/2020/05/11/donation-drive-continues-through-may-16-san-juan-college-campus/3101186001/</div><script>
window.simpleExclusion = window.simpleExclusion || [];
window.simpleTarget = window.simpleTarget || [];
Array.prototype.push.apply(window.simpleExclusion, ["disasters", "custom-facebook", "custom-abbive", "custom-quicken"]);
Array.prototype.push.apply(window.simpleTarget, ["disasters", "custom-facebook", "custom-abbive", "custom-quicken"]);
</script></div><aside class="story-right-rail"><section id="module-position-SsqYdXrI4OA" class="storyrightrail-bucket poster-ad-asset-module story-poster-ad-asset-module"><div class="partner-placement partner-asset-right-ad" data-ad-placement="poster" data-ad-sizes="[[300,250],[300,600],[300,1050]]"></div></section><section id="module-position-SsqYdXrkIsQ" class="storyrightrail-bucket jobs-search-module story-jobs-search-module"><div class="jobs-search-wrapper right-rail"><a class="jobs-search-logo-link" href="https://jobs.daily-times.com/Jobs/" data-track-label="thejobnetwork|thejobnetwork"><img class="jobs-search-logo" src="https://www.gannett-cdn.com/uxstatic/daily-times/uscp-web-static-4525.35.0/images/jobs-logo.png" /></a><div id="jobs-search-form" class="jobs-search-form" data-url="http://jobs.daily-times.com/Jobs/" data-affiliateId="3461"><div class="jobs-search-field"><input type="text" name="keyword" id="jobs-search-keyword" class="jobs-search-text-input jobs-search-keyword" placeholder="Keywords (ex. registered nurse)" autocomplete="off"></div><div class="jsm-search-suggestions jsm-keyword-suggestions hidden"><span class="jsm-close-icon"></span><ul id="jsm-keywords" class="jsm-suggestions-list jsm-keywords"></ul></div><div class="jobs-search-field"><input type="text" name="location" id="jobs-search-location" class="jobs-search-text-input jobs-search-location" value="Farmington, NM" placeholder="Location (ex. Chicago, IL or 50907)" autocomplete="off"></div><div class="jsm-search-suggestions jsm-location-suggestions hidden"><span class="jsm-close-icon"></span><ul id="jsm-locations" class="jsm-suggestions-list jsm-locations"></ul></div><div class="jobs-search-submit"><a class="jobs-search-btn"><span class="jobs-search-icon"></span><span class="jobs-search-btn-text">Find Jobs</span></a></div></div></div></section><section id="module-position-SsqYdXq-NBk" class="storyrightrail-bucket feedback-opinionlabs-module story-feedback-opinionlabs-module"><div class="fbol-container"><div class="fbol-content"><a class="fbol-link" href="#" data-analytics="survey_click_story" data-cta="rightrail">Share your feedback</a>
         to help improve our site experience!
    </div></div></section><section id="module-position-SsqYdXrzc2U" class="storyrightrail-bucket sponsor-button-ad-module story-sponsor-button-ad-module"><div class="partner-placement sponsor-button-ad" data-ad-placement="sponsor_button"  data-ad-sizes="[[300,50]]"></div></section><section id="module-position-SsqYdXqUMwc" class="storyrightrail-bucket taboola-poster-asset-module story-taboola-poster-asset-module"><div id="taboola-abp-right-rail-thumbnails"></div></section><section id="module-position-SsqYdXqXrTU" class="storyrightrail-bucket more-section-stories-module story-more-section-stories-module"><div class="story-ribbon" style=""><h6 class="story-ribbon-title">
    
        More Stories
    
</h6><div class="story-ribbon-content"><ul class="more-section-stories-list"><li class="more-section-stories-item first"><a class="more-section-stories-image-link" href="/story/news/local/2020/05/11/donation-drive-continues-through-may-16-san-juan-college-campus/3101186001/"   data-ht="morenewsstories"><img src="https://www.gannett-cdn.com/presto/2020/05/08/PNM7/1be7a91f-36c2-4dea-82a8-f643f8ae53cd-0P1A9208.JPG?crop=2577,2577,x766,y0&amp;width=80&amp;height=80&amp;fit=bounds" width="80" height="80" alt="Shirley Hoskie, the operations coordinator for the San Juan College physical plant, prepares to unload a trunkful of goods May 8 on the college campus during a donation drive for people on the Navajo Nation struggling from the COVID-19 shutdown." class="more-section-stories-thumb"/></a><h6 class="more-section-stories-headline"><a class="series-promo-headline-link" href="/story/news/local/2020/05/11/donation-drive-continues-through-may-16-san-juan-college-campus/3101186001/"    data-ht="morenewsstories">
                    College still seeking donations for Navajo Nation</a></h6><div class="more-section-stories-meta">
                    May 10, 2020, 6:11 p.m.
                </div></li><li class="more-section-stories-item "><a class="more-section-stories-image-link" href="/story/news/local/2020/05/09/san-juan-county-surpasses-grim-milestone-over-1000-coronavirus-cases/3103922001/"   data-ht="morenewsstories"><img src="https://www.gannett-cdn.com/presto/2020/04/15/PCCT/42d5f3eb-06d4-4bc0-9f86-d6977ab91541-coronavirus.jpg?crop=743,743,x288,y0&amp;width=80&amp;height=80&amp;fit=bounds" width="80" height="80" alt="Coronavirus" class="more-section-stories-thumb"/></a><h6 class="more-section-stories-headline"><a class="series-promo-headline-link" href="/story/news/local/2020/05/09/san-juan-county-surpasses-grim-milestone-over-1000-coronavirus-cases/3103922001/"    data-ht="morenewsstories">
                    San Juan County passes 1,000 coronavirus cases</a></h6><div class="more-section-stories-meta">
                    May 9, 2020, 5:13 p.m.
                </div></li><li class="more-section-stories-item "><a class="more-section-stories-image-link" href="/story/news/local/navajo-nation/2020/05/09/navajo-nation-oil-gives-free-propane-refills-part-coronavirus-response/3100452001/"   data-ht="morenewsstories"><img src="https://www.gannett-cdn.com/presto/2020/05/08/PNM7/afac9189-96ff-4425-94f5-00a9434477d9-FMN_Propane_0510_14.JPG?crop=3630,3630,x794,y0&amp;width=80&amp;height=80&amp;fit=bounds" width="80" height="80" alt="A propane tank is fitted on May 8 with a sleeve during the free propane refill service by Navajo Nation Oil and Gas Company and Nations Gas Technologies Inc. in Sanostee." class="more-section-stories-thumb"/></a><h6 class="more-section-stories-headline"><a class="series-promo-headline-link" href="/story/news/local/navajo-nation/2020/05/09/navajo-nation-oil-gives-free-propane-refills-part-coronavirus-response/3100452001/"    data-ht="morenewsstories">
                    Navajo companies team to offer free propane</a></h6><div class="more-section-stories-meta">
                    May 9, 2020, 9:30 a.m.
                </div></li><li class="more-section-stories-item "><a class="more-section-stories-image-link" href="/story/news/crime/2020/05/09/farmington-man-accused-stabbing-victim-face-neck-near-speedway-gas-station-knife/3097116001/"   data-ht="morenewsstories"><img src="https://www.gannett-cdn.com/presto/2020/05/08/PNM7/503c6433-33f3-44ee-b97d-c1b1f63695ad-FMN_Stabbing_0509.jpg?crop=317,317,x0,y73&amp;width=80&amp;height=80&amp;fit=bounds" width="80" height="80" alt="George Etcitty" class="more-section-stories-thumb"/></a><h6 class="more-section-stories-headline"><a class="series-promo-headline-link" href="/story/news/crime/2020/05/09/farmington-man-accused-stabbing-victim-face-neck-near-speedway-gas-station-knife/3097116001/"    data-ht="morenewsstories">
                    Man accused of stabbing victim in face, neck</a></h6><div class="more-section-stories-meta">
                    May 9, 2020, 8:58 a.m.
                </div></li><li class="more-section-stories-item "><a class="more-section-stories-image-link" href="/story/news/local/2020/05/08/san-juan-county-seeks-federal-funding-railroad-project/3100284001/"   data-ht="morenewsstories"><img src="https://www.gannett-cdn.com/presto/2020/02/20/PNM7/c8aa925d-2dfa-44cc-b903-acd5ace62095-FMN_Railroad_0221_04.jpg?crop=3456,3456,x1036,y0&amp;width=80&amp;height=80&amp;fit=bounds" width="80" height="80" alt="Navajo Nation President Jonathan Nez signs a memorandum of understanding with San Juan County, Thursday, Feb. 20, 2020, to collaborate on a railroad." class="more-section-stories-thumb"/></a><h6 class="more-section-stories-headline"><a class="series-promo-headline-link" href="/story/news/local/2020/05/08/san-juan-county-seeks-federal-funding-railroad-project/3100284001/"    data-ht="morenewsstories">
                    County seeks federal funding for rail project</a></h6><div class="more-section-stories-meta">
                    May 8, 2020, 6:03 p.m.
                </div></li><li class="more-section-stories-item "><a class="more-section-stories-image-link" href="/story/news/local/2020/05/08/hospital-ceo-urges-county-residents-take-steps-reduce-coronavirus-spread/3097345001/"   data-ht="morenewsstories"><img src="https://www.gannett-cdn.com/presto/2020/05/06/PNM7/f334aa31-869e-48cb-acc0-ec0a9de68dc8-COVID19TestTransport.JPG?crop=2432,2432,x547,y0&amp;width=80&amp;height=80&amp;fit=bounds" width="80" height="80" alt="Members of the New Mexico National Guard load COVID-19 test samples into an airplane on Wednesday, May 6, 2020, at Four Corners Regional Airport in Farmington. The test samples were flown out to Albuquerque and delivered to a laboratory being run by the New Mexico Department of Health." class="more-section-stories-thumb"/></a><h6 class="more-section-stories-headline"><a class="series-promo-headline-link" href="/story/news/local/2020/05/08/hospital-ceo-urges-county-residents-take-steps-reduce-coronavirus-spread/3097345001/"    data-ht="morenewsstories">
                    SJRMC CEO urges people to take steps to reduce COVID-19</a></h6><div class="more-section-stories-meta">
                    May 8, 2020, 4:44 p.m.
                </div></li></ul></div></div></section><section id="module-position-SsqYdXrBM8s" class="storyrightrail-bucket car-search-module story-car-search-module"></section><section id="module-position-SsqYdXqV4U8" class="storyrightrail-bucket poster-ad-asset2-module story-poster-ad-asset2-module"><div class="partner-asset-right-ad-2"><div class="poster-scroll"><div class="partner-placement poster-scroll-ad" data-ad-placement="poster_scroll" data-ad-sizes="[[300,250],[300,600],[300,1050]]"></div></div></div></section></aside><section id="module-position-SsqYdXunnlk" class="storybottombar-bucket taboola-related-module story-taboola-related-module"><div class="more more-stories-wrap"><div class="more-stories-content"><div id="js-taboola-wrapper"><div id="taboola-grid-3x3"></div><div id="taboola-organic-grid-3x3"></div><div id="taboola-short-article-2x5"></div><div id="taboola-organic-short-article-2x5"></div><div id="taboola-grid-sports-3x3"></div><div id="taboola-organic-grid-sports-3x3"></div></div></div></div><div class="clearfix"></div></section><section id="module-position-SsqYdXuGpCA" class="storybottombar-bucket leaderboard-ad-module story-leaderboard-ad-module"><div class="partner-placement leaderboard-btf-ad leaderboard-ad" data-ad-placement="leaderboard_btf" data-ad-sizes="[[728,90]]"></div></section><section id="module-position-SsqYdXv7q68" class="storymessaging-bucket persistent-meter-module story-persistent-meter-module"><cta-atoms-container-persistent-fixed></cta-atoms-container-persistent-fixed></section><footer class="site-footer clearfix site-footer-dr-styling"><ul class="utility"><li class="util-li first"><a class="help" href="https://help.daily-times.com/" data-ht="footersupport"><span class="big-icon"></span>Support</a></li><li class="util-li "><a class="contactus" href="http://static.daily-times.com/contactus/" data-ht="footercontact-us"><span class="big-icon"></span>Contact Us</a></li><li class="util-li "><a class="connectwithus" href="http://static.daily-times.com/connect/" data-ht="footerconnect-with-us"><span class="big-icon"></span>Connect With Us</a></li><li class="util-li "><a class="rss" href="http://static.daily-times.com/rss/" data-ht="footerrss"><span class="big-icon"></span>RSS</a></li><li class="util-li "><a class="apps" href="http://static.daily-times.com/apps/" data-ht="footerapps"><span class="big-icon"></span>Apps</a></li><li class="util-li "><a class="subscribe" href="https://subscribe.daily-times.com/specialoffer?gps-source=CPSUBFOOTER&amp;utm_medium=onsite&amp;utm_source=sitefooter&amp;utm_campaign=specialoffer&amp;utm_content=CPSUBFOOTER" data-ht="footersubscribe"><span class="big-icon"></span>Subscribe</a></li><li class="util-li last"><a class="help" href="/chatsupport" data-ht="footerchat-support"><span class="big-icon"></span>Chat Support</a></li></ul><div class="footer site-footer-fixed-width"><nav><div class="fronts"><section class="home"><h6><a href="/" data-ht="footerhome">Home</a></h6></section><section class="news"><h6><a href="/news/" data-ht="footernews">News</a></h6><ul class="site-footer-section-list site-footer-list"><li class="site-footer-section-item site-footer-list-item"><a class="site-footer-section-link site-footer-list-link" href="/section/global/elections/" data-ht="footerelections-2018">Elections 2018</a></li><li class="site-footer-section-item site-footer-list-item"><a class="site-footer-section-link site-footer-list-link" href="/news/san-juan-county/" data-ht="footersan-juan-county">San Juan County</a></li><li class="site-footer-section-item site-footer-list-item"><a class="site-footer-section-link site-footer-list-link" href="/news/navajo-nation/" data-ht="footernavajo-nation">Navajo Nation</a></li><li class="site-footer-section-item site-footer-list-item"><a class="site-footer-section-link site-footer-list-link" href="/section/global/washington/" data-ht="footernational-politics">National Politics</a></li><li class="site-footer-section-item site-footer-list-item"><a class="site-footer-section-link site-footer-list-link" href="http://www.publicnoticeads.com/NM/" data-ht="footerpublic-notices">PUBLIC NOTICES</a></li></ul></section><section class="sports"><h6><a href="/sports/" data-ht="footersports">Sports</a></h6><ul class="site-footer-section-list site-footer-list"><li class="site-footer-section-item site-footer-list-item"><a class="site-footer-section-link site-footer-list-link" href="http://daily-times.sportstonews.com/" data-ht="footergolf">Golf</a></li></ul></section><section class="business"><h6><a href="/business/" data-ht="footerbusiness">Business</a></h6><ul class="site-footer-section-list site-footer-list"><li class="site-footer-section-item site-footer-list-item"><a class="site-footer-section-link site-footer-list-link" href="/section/global/money_careers/" data-ht="footercareers">Careers</a></li></ul></section><section class="entertainment"><h6><a href="/entertainment/" data-ht="footerentertainment">Entertainment</a></h6></section><section class="lifestyle"><h6><a href="/lifestyle/" data-ht="footerlifestyle">Lifestyle</a></h6><ul class="site-footer-section-list site-footer-list"><li class="site-footer-section-item site-footer-list-item"><a class="site-footer-section-link site-footer-list-link" href="/lifestyle/outdoors/" data-ht="footeroutdoors">Outdoors</a></li><li class="site-footer-section-item site-footer-list-item"><a class="site-footer-section-link site-footer-list-link" href="/lifestyle/milestones/" data-ht="footermilestones">Milestones</a></li></ul></section><section class="opinion"><h6><a href="/opinion/" data-ht="footeropinion">Opinion</a></h6><ul class="site-footer-section-list site-footer-list"><li class="site-footer-section-item site-footer-list-item"><a class="site-footer-section-link site-footer-list-link" href="/opinion/editorials/" data-ht="footereditorials">Editorials</a></li><li class="site-footer-section-item site-footer-list-item"><a class="site-footer-section-link site-footer-list-link" href="/opinion/letters-to-the-editor/" data-ht="footerletters-to-the-editor">Letters to the Editor</a></li><li class="site-footer-section-item site-footer-list-item"><a class="site-footer-section-link site-footer-list-link" href="/opinion/columns/" data-ht="footercolumns">Columns</a></li></ul></section><section class="obituaries"><h6><a href="https://www.legacy.com/obituaries/daily-times/" data-ht="footerobituaries">Obituaries</a></h6></section><section class="homes site-footer-section-more"><h6><a href="/marketplace/real-estate/" data-ht="footerhomes">Homes</a></h6></section><section class="usa-today site-footer-section-more"><h6><a href="https://www.usatoday.com" data-ht="footerusa-today">USA Today</a></h6></section><section class="public-notices site-footer-section-more"><h6><a href="http://www.publicnoticeads.com/NM/" data-ht="footerpublic-notices">Public Notices</a></h6></section><section class="classifieds site-footer-section-more"><h6><a href="http://classifieds.daily-times.com/" data-ht="footerclassifieds">Classifieds</a></h6></section><section class="business-directory site-footer-section-more"><h6><a href="https://local.daily-times.com/" data-ht="footerbusiness-directory">Business Directory</a></h6></section><section class="celebrations site-footer-section-more"><h6><a href="http://www.legacy.com/celebration/daily-times/" data-ht="footercelebrations">Celebrations</a></h6></section><section class="in-memoriam site-footer-section-more"><h6><a href="https://www.legacy.com/obituaries/daily-times/" data-ht="footerin-memoriam">In Memoriam</a></h6></section></div><section class="site-footer-meta site-footer-meta-fixed-width"><img src="https://www.gannett-cdn.com/sites/daily-times/images/footer-logo@2x.png" class="site-footer-logo" alt="Farmington Daily Times"><ul class="site-footer-social-icon-list site-footer-social-icon-list-fixed-width"><li class="site-footer-social-icon-item"><a class="soc-fb site-footer-social-icon-link site-footer-social-icon-link-soc-fb" href="https://www.facebook.com/FDTNews" data-uotrack="footerfacebook" rel="nofollow"></a></li><li class="site-footer-social-icon-item"><a class="soc-tw site-footer-social-icon-link site-footer-social-icon-link-soc-tw" href="https://twitter.com/TheDailyTimes" data-uotrack="footertwitter" rel="nofollow"></a></li><li class="site-footer-social-icon-item"><a class="soc-gp site-footer-social-icon-link site-footer-social-icon-link-soc-gp" href="https://plus.google.com/106675728599016521327/posts" data-uotrack="footergoogle-plus" rel="publisher nofollow"></a></li></ul><p class="site-footer-meta-text site-footer-meta-text-fixed-width">&copy; 2020 daily-times.com, All rights reserved.</p></section><section class="services site-footer-section-services site-footer-section-services-fixed-width"><h3>Services</h3><ul class="site-footer-list"><li class="site-footer-list-item"><a class="site-footer-list-link  "
                                   href="https://cm.daily-times.com/advertising-terms-conditions"
                                data-ht="footeradvertising-terms-and-conditions"
                                >Advertising Terms and Conditions</a></li><li class="site-footer-list-item"><a class="site-footer-list-link  "
                                   href="http://www.gannett.com/careers/"
                                data-ht="footerwork-with-us"
                                >Work With Us</a></li><li class="site-footer-list-item"><a class="site-footer-list-link  "
                                   href="https://cm.daily-times.com/terms"
                                data-ht="footerterms-of-service"
                                >Terms of Service</a></li><li class="site-footer-list-item"><a class="site-footer-list-link  "
                                   href="https://cm.daily-times.com/community"
                                data-ht="footercommunity-rules"
                                >Community Rules</a></li><li class="site-footer-list-item"><a class="site-footer-list-link  "
                                   href="https://cm.daily-times.com/privacy-policy"
                                data-ht="footeryour-california-privacy-rightsprivacy-policy"
                                >Your California Privacy Rights/Privacy Policy</a></li><li class="site-footer-list-item"><a class="site-footer-list-link  "
                                   href="/subscriberguide/"
                                data-ht="footersubscriber-guide"
                                target="_blank"
                                >Subscriber Guide</a></li><li class="site-footer-list-item"><a class="site-footer-list-link  "
                                   href="https://cm.daily-times.com/ethical-conduct"
                                data-ht="footerour-ethical-principles"
                                >Our Ethical Principles</a></li><li class="site-footer-list-item"><a class="site-footer-list-link  "
                                   href="https://cm.daily-times.com/accessibility"
                                data-ht="footeraccessibility-support"
                                >Accessibility Support</a></li><li class="site-footer-list-item"><a class="site-footer-list-link  "
                                   href="http://www.publicnoticeads.com/NM/"
                                data-ht="footerpublic-notices"
                                >Public Notices</a></li><li class="site-footer-list-item"><a class="site-footer-list-link  "
                                   href="/sitemap/"
                                data-ht="footersitemap"
                                >Sitemap</a></li></ul><ul class="site-footer-list"><li class="site-footer-list-item"><a class="site-footer-list-link " href="https://cm.daily-times.com/privacy" data-ht="footerprivacy-policy">Privacy Policy</a></li><li class="site-footer-list-item"><a class="site-footer-list-link ot-sdk-show-settings" href="#" data-ht="footerdo-not-sell-my-infocookie-policy">Do Not Sell My Info/Cookie Policy</a></li></ul></section><section class="partners site-footer-section-partners site-footer-section-partners-fixed-width"><h3>Our Partners</h3><ul class="site-footer-list"><li class="site-footer-list-item"><a class="site-footer-list-link" href="https://www.cars.com/shopping/farmington-nm/" data-ht="footercarscom-farmington" rel="nofollow ">Cars.com Farmington</a></li><li class="site-footer-list-item"><a class="site-footer-list-link" href="http://jobs.daily-times.com" data-ht="footerthe-job-network" rel="nofollow ">The Job Network</a></li><li class="site-footer-list-item"><a class="site-footer-list-link" href="https://www.thanksgiving.com" data-ht="footerthanksgivingcom" rel="nofollow ">Thanksgiving.com</a></li><li class="site-footer-list-item"><a class="site-footer-list-link" href="http://classifieds.daily-times.com" data-ht="footerclassifieds" rel="nofollow ">Classifieds</a></li><li class="site-footer-list-item"><a class="site-footer-list-link" href="https://www.legacy.com/obituaries/daily-times/" data-ht="footerin-memoriam" rel="nofollow ">In Memoriam</a></li><li class="site-footer-list-item"><a class="site-footer-list-link" href="https://grateful.co" data-ht="footergrateful" rel="nofollow ">Grateful</a></li><li class="site-footer-list-item"><a class="site-footer-list-link" href="http://www.legacy.com/celebration/daily-times/" data-ht="footercelebrations" rel="nofollow ">Celebrations</a></li></ul></section></nav></div></footer><!-- comscorekw=news --><script type="json/pageinfo" class="pageinfo">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</script></article></div><div class="arrows overlay-arrows"><script type="text/template" id="overlay-arrow-wrap"><% if (disabled) { %><a class="overlay-content-arrows overlay-arrows-<%= dir %>-wrap <%= disabled %>" data-ht="articlearrow<%= dir %>"></a><% }else{ %><a class="overlay-content-arrows overlay-content-arrows-<%= dir %>-wrap <%= disabled %>" href="<%= links %>" data-ht="articlearrow<%= dir %>"><div class="overlay-arrow-<%= dir %> overlay-arrows-anchor"><div class="overlay-arrows-<%= dir %>-anchor-image"></div></div></a><% } %></script></div></div><div id="overlay-film" class="ui-film show"></div><div id="ad-staging"></div><div class="partner-popup"></div><!--[if lt IE 9]><script type="text/javascript" src="https://www.gannett-cdn.com/uxstatic/daily-times/uscp-web-static-4525.35.0/jsb/main_legacy.min.js"></script><![endif]--><!--[if gt IE 8]><!--><script type="text/javascript" src="https://www.gannett-cdn.com/uxstatic/daily-times/uscp-web-static-4525.35.0/jsb/main.min.js"></script><!--<![endif]--><script src="https://login.gcion.com/GANNETT-GUP/resources/kit/js/norequirejs.common.min.js" id="jskit"></script><script type="text/javascript">
        
        require(["gdp-usf/kit/js/user_factory_def", "gdp-usf/kit/js/feature_personalized_link_def", "gdp-usf/kit/js/client_helpers"],
            function(UserFactory, PersonalizedLinkFactory, ClientHelpers) {
                window.UserFactory = UserFactory;
                window.PersonalizedLinkFactory = PersonalizedLinkFactory;
                window.ClientHelpers = ClientHelpers;
            }
        );
        </script><div id="fb-root"></div><script src="https://www.gannett-cdn.com/appservices/gidgits-js/gidgits.min.js" id="gidgits-script"></script><script type="text/javascript">
        var mainAd = document.createElement('div');
        mainAd.id = 'main_ad';
        mainAd.style.cssText = 'height:1px; width:1px; overflow:auto;position: absolute;left: -999em;';
        document.body.appendChild(mainAd);
        var blockPosition = document.getElementById('main_ad');
        if(blockPosition && blockPosition.offsetHeight == 1) {
            window.adsEnabled = true;
        }
    </script><script>
/* Wrapper for Gannett, generated on 2018-11-08T16:48:57-05:00 */
(function() {
    var e, s;
    var config = (window.site_vars && window.site_vars.ADS && window.site_vars.ADS.confiant) ? window.site_vars.ADS.confiant : {};
    var cb = function(blockingType, blockingId, isBlocked, wrapperId, tagId, impressionData) {

        // Log block event to NewRelic
        if (window.newrelic) {
            window.newrelic.addPageAction('advertisingConfiant', {
                blockingType: blockingType,
                blockingId: blockingId,
                isBlocked: isBlocked,
                wrapperId: wrapperId,
                tagId: tagId
            });
        }

        // Refresh blocked ads
        if (config.refreshBlocked) {
            var slotId = impressionData && impressionData.dfp && impressionData.dfp.s;
            if (slotId && window.adManager && window.adManager.activeSlotStatistics && window.adManager.activeSlotStatistics.slots) {
                window.googletag = window.googletag || {};
                window.googletag.cmd = window.googletag.cmd || [];
                window.googletag.cmd.push(function () {
                    window.adManager.activeSlotStatistics.slots.forEach(function (slot) {
                        if (slot.id === slotId && slot.adSlot) {
                            slot.adSlot.refresh();
                        }
                    })
                });
            }
        }
    };

    if (config.enabled || window.location.search.indexOf('confiant_debug') !== -1) {
        window.confiant = window.confiant || {};
        window.confiant.enable_integrations = ['gpt'];
        window.confiant.callback = cb;

        e = document.createElement('script');
        e.async = true;
        e.src = config && config.scriptUrl || 'https://confiant-integrations.global.ssl.fastly.net/r5TdgVvkbv-PeaJCKaQfCh5Xsto/gpt_and_prebid/config.js';
        s = document.getElementsByTagName('script')[0];
        s.parentNode.insertBefore(e, s);

    }
})();
</script></body></html>
